aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gnustep-make
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2005-07-10 16:21:08 +0800
committerdinoex <dinoex@FreeBSD.org>2005-07-10 16:21:08 +0800
commit53a4856d9a2216bbf9d6e0bf67bebbbe1dc45a8f (patch)
tree07a9441c8f4b77135dcc9c4d4a722666d8ac28d6 /devel/gnustep-make
parentf596f4cada6641bd9548ad26ff132c3d313289d6 (diff)
downloadfreebsd-ports-gnome-53a4856d9a2216bbf9d6e0bf67bebbbe1dc45a8f.tar.gz
freebsd-ports-gnome-53a4856d9a2216bbf9d6e0bf67bebbbe1dc45a8f.tar.zst
freebsd-ports-gnome-53a4856d9a2216bbf9d6e0bf67bebbbe1dc45a8f.zip
- warn about bad ldconfig paths
Diffstat (limited to 'devel/gnustep-make')
-rw-r--r--devel/gnustep-make/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/devel/gnustep-make/Makefile b/devel/gnustep-make/Makefile
index 8e2d6043e06a..e4f849fea497 100644
--- a/devel/gnustep-make/Makefile
+++ b/devel/gnustep-make/Makefile
@@ -37,18 +37,24 @@ GNUSTEP_WITHOUT_LIBOBJC= yes
BROKEN= "Configure fails on FreeBSD >= 5.x"
.endif
+.if !defined(GNUSTEP_WITH_BASE_GCC)
pre-configure:
@if test ! -f "${TARGLIB}/libobjc.so"; then \
${ECHO_MSG} "libobjc.so not found, please update your gcc"; \
${FALSE}; \
fi; \
- if test `${LDCONFIG} -r | ${GREP} libobjc.so | wc -l` -eq 0; then \
+ if test `${LDCONFIG} -r | ${GREP} "${TARGLIB}/libobjc.so" | wc -l` -eq 0; then \
${ECHO_MSG} "trying to fix ldconfig.hints"; \
${LDCONFIG} -f "${WRKDIR}/ldconfig.hints" -m "${TARGLIB}";\
- if test `${LDCONFIG} -f "${WRKDIR}/ldconfig.hints" -r | ${GREP} libobjc.so | wc -l` -eq 0; then \
+ if test `${LDCONFIG} -f "${WRKDIR}/ldconfig.hints" -r | ${GREP} "${TARGLIB}/libobjc.so" | wc -l` -eq 0; then \
${ECHO_MSG} "libobjc.so not in path"; \
${FALSE}; \
fi; \
- fi; \
+ fi;
+.endif
+
+.if defined(PARALLEL_PACKAGE_BUILD)
+NO_PACKAGE= yes
+.endif
.include <bsd.port.post.mk>