aboutsummaryrefslogtreecommitdiffstats
path: root/devel/google-gdata/Makefile
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2018-01-31 03:00:27 +0800
committerdbn <dbn@FreeBSD.org>2018-01-31 03:00:27 +0800
commit243bd66399d97867f5ba672f7071777717d11187 (patch)
treef565b3312e4715c9ab2c5543a2fb9b40d667713b /devel/google-gdata/Makefile
parentec472cf724c63102852d138e673cb67b40f914c1 (diff)
downloadfreebsd-ports-gnome-243bd66399d97867f5ba672f7071777717d11187.tar.gz
freebsd-ports-gnome-243bd66399d97867f5ba672f7071777717d11187.tar.zst
freebsd-ports-gnome-243bd66399d97867f5ba672f7071777717d11187.zip
lang/mono: update to version 5.2.0.215 (and enhance USES=mono)
Highlights: - New Roslyn compiler for C# available - Improved support for nuget packages in USES=mono General: - fix pkg-plist: mono now produces '.pdb' debug files instead of '.mdb' - bump all dependant ports USES=mono: - properly handle caching of nuget packages - add support for multiple feeds for nuget packages - add support for nuget dependencies in a separate file - add support for paket packages lang/mono: - update to version 5.2.0.215 - automate certificate initialisation [2] - increase test coverage - mark as conflicting with net/czmq (conflicting on makecert) [1] - patch mono to use $PREFIX/share/mono instead of /usr/share/.mono devel/google-gdata: - use nunit.framework nuget package as the Mono shipped version is no longer suppport. - switch to using csc(1) for compiling (mcs(1) is depreciated). - use delayed signing (and then sign with sn(1)) as csc(1) does not support signing. - fix reference to system assemblies (the '.dll' suffix is required). - fix reference to HttpUtility: csc(1) is more strict about scoping devel/monodevelop: - reroll distinfo (no changes to content) lang/fsharp: - reroll distinfo (no changes to content) security/gnome-keyring-sharp: - delay sign (then sign with sn(1)) as csc(1) does not support direct signing. PR: 223188 [1] PR: 209670 [2] Differential Revision: https://reviews.freebsd.org/D13752
Diffstat (limited to 'devel/google-gdata/Makefile')
-rw-r--r--devel/google-gdata/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/devel/google-gdata/Makefile b/devel/google-gdata/Makefile
index f9736f4cd163..e2f13b9daf9d 100644
--- a/devel/google-gdata/Makefile
+++ b/devel/google-gdata/Makefile
@@ -3,7 +3,7 @@
PORTNAME= google-gdata
PORTVERSION= 2.2.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MAINTAINER= bofh@FreeBSD.org
@@ -12,20 +12,21 @@ COMMENT= DOT NET library for the Google Data API
LICENSE= APACHE20
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/Newtonsoft.Json.pc:devel/newtonsoft-json
+NUGET_DEPENDS= nunit.framework=2.63.0
USE_GITHUB= yes
GH_ACCOUNT= google
GH_TAGNAME= edcd096379
-USES= dos2unix gmake mono pathfix
+USES= dos2unix gmake mono:nuget pathfix
PATHFIX_MAKEFILEIN= Makefile
WRKSRC_SUBDIR= clients/cs
DOS2UNIX_FILES= ${WRKSRC}/Makefile ${WRKSRC}/misc/gdata-sharp-core.pc.in
-MAKE_ARGS= CSC=${LOCALBASE}/bin/mcs
+MAKE_ARGS= CSC=${LOCALBASE}/bin/csc SN=${LOCALBASE}/bin/sn
NO_ARCH= yes
post-patch:
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' -Ee 's|(-keyfile:(.*))|\1 -delaysign+\'$$'\n'$$'\t''$$(SN) -R $$@ \2|g' ${WRKSRC}/Makefile
post-install:
cd ${STAGEDIR}${PREFIX}; ${FIND} lib/mono libdata/pkgconfig \