aboutsummaryrefslogtreecommitdiffstats
path: root/devel/grpc
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2019-06-29 11:51:13 +0800
committertobik <tobik@FreeBSD.org>2019-06-29 11:51:13 +0800
commit01937667a99ad7ce0fe80e148aef97dd7683f94c (patch)
tree8c7c440762c72012824110ba9cdd44c8c1765017 /devel/grpc
parent388b5eef103bfb24dd783b7f2c5dd9f7cf45e08a (diff)
downloadfreebsd-ports-gnome-01937667a99ad7ce0fe80e148aef97dd7683f94c.tar.gz
freebsd-ports-gnome-01937667a99ad7ce0fe80e148aef97dd7683f94c.tar.zst
freebsd-ports-gnome-01937667a99ad7ce0fe80e148aef97dd7683f94c.zip
Convert all Go ports to USES=go
This allows for port testing with lang/go-devel via GO_PORT, setting up the Go build environment in a single place, and is step one in simplifying Go ports that often define too complicated do-build targets themselves. USES=go gains new arguments 'run' to add lang/go to RUN_DEPENDS and 'no_targets' for ports with composite builds that call 'go' themselves and do not need the do-build/do-install targets of USES=go. PR: 238849 Submitted by: dg@syrec.org (also D20745) Reviewed by: mat, tobik Exp-run by: antoine Differential Revision: https://reviews.freebsd.org/D20746
Diffstat (limited to 'devel/grpc')
-rw-r--r--devel/grpc/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/grpc/Makefile b/devel/grpc/Makefile
index abe320a833a5..e710e0effd5b 100644
--- a/devel/grpc/Makefile
+++ b/devel/grpc/Makefile
@@ -13,13 +13,13 @@ COMMENT= HTTP/2-based RPC framework
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= go:lang/go \
- yasm:devel/yasm
+BUILD_DEPENDS= yasm:devel/yasm
LIB_DEPENDS= libgflags.so:devel/gflags \
libprotobuf.so:devel/protobuf \
libcares.so:dns/c-ares
-USES= cmake localbase:ldflags perl5 pkgconfig ssl
+USES= cmake go:no_targets localbase:ldflags perl5 pkgconfig ssl
+
USE_GITHUB= yes
GH_TUPLE= google:benchmark:v1.4.1:benchmark/third_party/benchmark
USE_LDCONFIG= yes