aboutsummaryrefslogtreecommitdiffstats
path: root/devel/guichan/Makefile
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-10-14 02:24:53 +0800
committermnag <mnag@FreeBSD.org>2005-10-14 02:24:53 +0800
commit7b6462cc09eabf8e68e86ee142e9d621a0953f87 (patch)
tree6fffaad9549cffe04bed424e792b22f670146f90 /devel/guichan/Makefile
parent0072df6341211df398cbf0967e401c3b45b37e23 (diff)
downloadfreebsd-ports-gnome-7b6462cc09eabf8e68e86ee142e9d621a0953f87.tar.gz
freebsd-ports-gnome-7b6462cc09eabf8e68e86ee142e9d621a0953f87.tar.zst
freebsd-ports-gnome-7b6462cc09eabf8e68e86ee142e9d621a0953f87.zip
Fix configure to detect SDL
Bump PORTREVISION Submitted by: maintainer via email
Diffstat (limited to 'devel/guichan/Makefile')
-rw-r--r--devel/guichan/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/devel/guichan/Makefile b/devel/guichan/Makefile
index 8a4e4713dfea..228c971a2fa4 100644
--- a/devel/guichan/Makefile
+++ b/devel/guichan/Makefile
@@ -7,6 +7,7 @@
PORTNAME= guichan
PORTVERSION= 0.4.0
+PORTREVISION= 1
CATEGORIES= devel games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,11 +16,10 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= freebsd@gionet.de
COMMENT= A small, efficient C++ GUI library designed for games
-LIB_DEPENDS= SDL-1.1.7:${PORTSDIR}/devel/sdl12 \
- SDL_image.10:${PORTSDIR}/graphics/sdl_image
-
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_REINPLACE= yes
+USE_SDL= sdl image
USE_GMAKE= yes
USE_GCC= 3.2+
USE_LIBTOOL_VER=15
@@ -32,7 +32,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/SDL11 \
-I${X11BASE}/include" LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib \
${PTHREAD_LIBS}"
-pre-configure:
- @(cd ${WRKSRC} && ./autogen.sh)
+post-patch:
+ @${REINPLACE_CMD} -e "s|%%SDL_CONFIG_ONLY%%|${SDL_CONFIG:S/${PREFIX}\/bin\///}|g" \
+ -e "s|%%SDL_CONFIG%%|${SDL_CONFIG}|g" ${WRKSRC}/configure
.include <bsd.port.mk>