aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gwenhywfar
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2012-10-23 01:50:13 +0800
committerjhale <jhale@FreeBSD.org>2012-10-23 01:50:13 +0800
commitc86f9de16ec4b9f5dd181c929d3030cd1589a7ad (patch)
tree9bf1fd46dea4fd34abad7f86dcf146dbd234b557 /devel/gwenhywfar
parentf23eb3914017528493ae6cbc0bb0fad96ed604e4 (diff)
downloadfreebsd-ports-gnome-c86f9de16ec4b9f5dd181c929d3030cd1589a7ad.tar.gz
freebsd-ports-gnome-c86f9de16ec4b9f5dd181c929d3030cd1589a7ad.tar.zst
freebsd-ports-gnome-c86f9de16ec4b9f5dd181c929d3030cd1589a7ad.zip
- Generate plist for DOXYGEN option independent of the PORTDOCS macro
to avoid problems if NOPORTDOCS is defined Approved by: makc (mentor, implicit) Feature safe: yes
Diffstat (limited to 'devel/gwenhywfar')
-rw-r--r--devel/gwenhywfar/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/devel/gwenhywfar/Makefile b/devel/gwenhywfar/Makefile
index 62a813c95b21..d0faf55f7f69 100644
--- a/devel/gwenhywfar/Makefile
+++ b/devel/gwenhywfar/Makefile
@@ -40,11 +40,10 @@ GWEN_SHLIB_VER= 60
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MDOXYGEN}
+.if ${PORT_OPTIONS:MDOXYGEN}
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen \
dot:${PORTSDIR}/graphics/graphviz
CONFIGURE_ARGS+=--enable-full-doc
-PORTDOCS= apidoc
.endif
.if ${PORT_OPTIONS:MMEMDEBUG}
@@ -79,15 +78,19 @@ post-patch:
.endif
post-build:
-.if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MDOXYGEN}
+.if ${PORT_OPTIONS:MDOXYGEN}
@cd ${WRKSRC} && ${GMAKE} srcdoc
.endif
post-install:
-.if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MDOXYGEN}
+.if ${PORT_OPTIONS:MDOXYGEN}
${MKDIR} ${DOCSDIR}/apidoc
cd ${WRKSRC}/apidoc && \
${COPYTREE_SHARE} \* ${DOCSDIR}/apidoc
+ @${FIND} -P ${DOCSDIR} -type f 2>/dev/null | \
+ ${SED} -ne 's,^${PREFIX}/,,p' >> ${TMPPLIST}
+ @${FIND} -P -d ${DOCSDIR} -type d 2>/dev/null | \
+ ${SED} -ne 's,^${PREFIX}/,@dirrm ,p' >> ${TMPPLIST}
.endif
.include <bsd.port.mk>