aboutsummaryrefslogtreecommitdiffstats
path: root/devel/hadoop2
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-05-14 18:15:04 +0800
committermat <mat@FreeBSD.org>2015-05-14 18:15:04 +0800
commitd72353c225a0cff8478c442d745a54e4630671fc (patch)
tree627649ff7699a289d5d78c11bf8d105881402ca8 /devel/hadoop2
parent7790dd541328e5000ba710fc478bc5f22ab41cc6 (diff)
downloadfreebsd-ports-gnome-d72353c225a0cff8478c442d745a54e4630671fc.tar.gz
freebsd-ports-gnome-d72353c225a0cff8478c442d745a54e4630671fc.tar.zst
freebsd-ports-gnome-d72353c225a0cff8478c442d745a54e4630671fc.zip
MASTER_SITES cleanup.
- Replace ${MASTER_SITE_FOO} with FOO. - Merge MASTER_SITE_SUBDIR into MASTER_SITES when possible. (This means 99.9% of the time.) - Remove occurrences of MASTER_SITE_LOCAL when no subdirectory was present and no hint of what it should be was present. - Fix some logic. - And generally, make things more simple and easy to understand. While there, add magic values to the FESTIVAL, GENTOO, GIMP, GNUPG, QT and SAMBA macros. Also, replace some EXTRACT_SUFX occurences with USES=tar:*. Checked by: make fetch-urlall-list With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'devel/hadoop2')
-rw-r--r--devel/hadoop2/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/devel/hadoop2/Makefile b/devel/hadoop2/Makefile
index fb616973ef4c..f4fff3b87a74 100644
--- a/devel/hadoop2/Makefile
+++ b/devel/hadoop2/Makefile
@@ -8,15 +8,15 @@
PORTNAME= hadoop
PORTVERSION= 2.6.0
CATEGORIES= devel java
-MASTER_SITES= ${MASTER_SITE_APACHE} \
+MASTER_SITES= APACHE/${PORTNAME}/common/stable \
LOCAL/demon/:maven \
http://archive.apache.org/dist/tomcat/tomcat-6/v${TOMCAT_VERSION}/bin/:tomcat \
http://dist.codehaus.org/jetty/jetty-6.1.14/:jetty
-MASTER_SITE_SUBDIR=${PORTNAME}/common/stable
PKGNAMESUFFIX= 2
-DISTFILES= ${PORTNAME}-${PORTVERSION}-src${EXTRACT_SUFX} FreeBSD-hadoop2-${PORTVERSION}-maven-repository.tar.gz:maven apache-tomcat-${TOMCAT_VERSION}.tar.gz:tomcat jetty-6.1.14.zip:jetty
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} FreeBSD-hadoop2-${PORTVERSION}-maven-repository.tar.gz:maven apache-tomcat-${TOMCAT_VERSION}.tar.gz:tomcat jetty-6.1.14.zip:jetty
DIST_SUBDIR= hadoop
-EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}-src${EXTRACT_SUFX} FreeBSD-hadoop2-${PORTVERSION}-maven-repository.tar.gz jetty-6.1.14.zip
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX} FreeBSD-hadoop2-${PORTVERSION}-maven-repository.tar.gz jetty-6.1.14.zip
MAINTAINER= demon@FreeBSD.org
COMMENT= Apache Map/Reduce framework
@@ -39,7 +39,6 @@ JAVA_VERSION= 1.7+
USE_LDCONFIG= yes
SHEBANG_FILES= hadoop-hdfs-project/hadoop-hdfs-httpfs/src/main/sbin/httpfs.sh hadoop-hdfs-project/hadoop-hdfs-httpfs/src/main/libexec/httpfs-config.sh hadoop-common-project/hadoop-kms/src/main/sbin/kms.sh hadoop-common-project/hadoop-kms/src/main/libexec/kms-config.sh
MAKE_ENV+= HADOOP_PROTOC_PATH=${LOCALBASE}/protobuf25/bin/protoc
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src
OPTIONS_DEFINE= EXAMPLES
OPTIONS_DEFAULT= EXAMPLES