aboutsummaryrefslogtreecommitdiffstats
path: root/devel/hp48cc
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-01-28 16:03:33 +0800
committerbapt <bapt@FreeBSD.org>2014-01-28 16:03:33 +0800
commit7ccdcbefb75ea37889a6766eb339e360ee39dcb6 (patch)
tree330598df81ce1c35ba13f8b0d15113a79d953d14 /devel/hp48cc
parenta859247da16aeb724444daca8db143b63df840e9 (diff)
downloadfreebsd-ports-gnome-7ccdcbefb75ea37889a6766eb339e360ee39dcb6.tar.gz
freebsd-ports-gnome-7ccdcbefb75ea37889a6766eb339e360ee39dcb6.tar.zst
freebsd-ports-gnome-7ccdcbefb75ea37889a6766eb339e360ee39dcb6.zip
Support stage
Add a EXAMPLES option
Diffstat (limited to 'devel/hp48cc')
-rw-r--r--devel/hp48cc/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/devel/hp48cc/Makefile b/devel/hp48cc/Makefile
index 671f41e102f2..01c368ae8f7a 100644
--- a/devel/hp48cc/Makefile
+++ b/devel/hp48cc/Makefile
@@ -13,28 +13,25 @@ COMMENT= C-like compiler that translates input code to the HP48 RPL language
LICENSE= GPLv2
+OPTIONS_DEFINE= EXAMPLES
+
USES= bison
GNU_CONFIGURE= yes
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
-MAN1= ${PORTNAME}.1
-PLIST_FILES= bin/${PORTNAME}
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz
PORTEXAMPLES= *
OPTIONS_DEFINE= EXAMPLES
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
post-patch:
# Fix the Makefile to unbreak parallel builds
@${REINPLACE_CMD} -e 's,(YACC),& -o parser.c, ; \
s,(LEX),& -olexer.c, ; /mv/d' ${WRKSRC}/src/Makefile.in
post-install:
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>