aboutsummaryrefslogtreecommitdiffstats
path: root/devel/hp48xgcc
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2006-09-05 04:25:28 +0800
committerdanfe <danfe@FreeBSD.org>2006-09-05 04:25:28 +0800
commitb38ce829016e5edb66fe1050b09695a7088b20c0 (patch)
tree6b1d4de6b93efa5ec2f028fbd5bf8885a7b91728 /devel/hp48xgcc
parentfdd0e10118390ac15c71db3d248cb9dc1137befc (diff)
downloadfreebsd-ports-gnome-b38ce829016e5edb66fe1050b09695a7088b20c0.tar.gz
freebsd-ports-gnome-b38ce829016e5edb66fe1050b09695a7088b20c0.tar.zst
freebsd-ports-gnome-b38ce829016e5edb66fe1050b09695a7088b20c0.zip
- Unbreak the build with recent GNU make
- No longer DEPRECATED
Diffstat (limited to 'devel/hp48xgcc')
-rw-r--r--devel/hp48xgcc/Makefile4
-rw-r--r--devel/hp48xgcc/files/patch-Makefile13
2 files changed, 10 insertions, 7 deletions
diff --git a/devel/hp48xgcc/Makefile b/devel/hp48xgcc/Makefile
index b2dc016b97c8..a287c0f86cc9 100644
--- a/devel/hp48xgcc/Makefile
+++ b/devel/hp48xgcc/Makefile
@@ -40,11 +40,7 @@ MAKE_ARGS= GCC_SRC="${GCC_DIR}" GCC_VERSION="${GCC_VER}" \
.if ${ARCH} != "i386"
BROKEN= Configure fails on !i386
-.else
-BROKEN= fails to install
.endif
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2006-12-01
post-extract: .SILENT
# Extract GCC distribution separately because of USE_ZIP/.tar.gz conflict
diff --git a/devel/hp48xgcc/files/patch-Makefile b/devel/hp48xgcc/files/patch-Makefile
index 42538c1cee04..e6bda877f5a4 100644
--- a/devel/hp48xgcc/files/patch-Makefile
+++ b/devel/hp48xgcc/files/patch-Makefile
@@ -1,6 +1,6 @@
--- Makefile.orig Thu Nov 7 18:58:32 1996
+++ Makefile Mon Feb 20 18:49:33 2006
-@@ -34,19 +34,20 @@
+@@ -34,40 +34,43 @@
CLASS_SRC = ./class
MKDIRHIER = mkdir -p
@@ -26,8 +26,15 @@
zip: hp48xgcc-$(VERSION_TAG).zip
-@@ -57,17 +58,18 @@
+-usr-tree: FORCE
+- cd $(GCC_SRC); perl -e '\
+- foreach $$t("cccp", "xgcc", "cc1") { \
++USR_TREE = 'foreach $$t("cccp", "xgcc", "cc1") { \
+ if(-e $$t && !-e "$$t$(EXE)") { unlink $$t; } \
elsif(!-e $$t && -e "$$t$(EXE)") { unlink "$$t$(EXE)"; } }'
++
++usr-tree: FORCE
++ cd $(GCC_SRC); perl -e $(USR_TREE)
$(MAKE) -C $(GCC_SRC) $(GCC_MAKE_ARGS) xgcc cc1 cccp
$(MAKE) -e -C $(CLASS_SRC)
- $(MAKE) usr-tree1
@@ -48,7 +55,7 @@
public-files: $(addprefix $(INSTPUB)/,$(PUBDIRS)) \
$(addprefix $(INSTPUB)/,$(PUBFILES))
-@@ -76,22 +78,25 @@
+@@ -76,22 +79,25 @@
cd $(ROOT) && zip -uyr $@ usr
$(INSTBIN)/xgcc$(EXE): $(GCC_SRC)/xgcc$(EXE)