aboutsummaryrefslogtreecommitdiffstats
path: root/devel/hs-git-annex
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2014-01-10 05:32:12 +0800
committerpgj <pgj@FreeBSD.org>2014-01-10 05:32:12 +0800
commit1e8ecc139a38c58921cfe6dbac98c727b1cefd71 (patch)
tree604f06bea271b71fb7be1993c1c2ba323b4506e1 /devel/hs-git-annex
parent85c277ebe0c60dd6aa5be2bceb4d04e10cdf1b13 (diff)
downloadfreebsd-ports-gnome-1e8ecc139a38c58921cfe6dbac98c727b1cefd71.tar.gz
freebsd-ports-gnome-1e8ecc139a38c58921cfe6dbac98c727b1cefd71.tar.zst
freebsd-ports-gnome-1e8ecc139a38c58921cfe6dbac98c727b1cefd71.zip
- Stagify lang/ghc and all the Haskell Cabal ports
- Update HACKAGE_SITE to follow changes in upstream - MAKE_ENV now sets LC_ALL and DESTDIR for Haskell Cabal ports - Further minor cosmetical changes: replace USE_GMAKE with USES, get rid of ${DO_NADA}, some refactoring Obtained from: FreeBSD Haskell
Diffstat (limited to 'devel/hs-git-annex')
-rw-r--r--devel/hs-git-annex/Makefile6
-rw-r--r--devel/hs-git-annex/files/patch-Setup.hs35
2 files changed, 38 insertions, 3 deletions
diff --git a/devel/hs-git-annex/Makefile b/devel/hs-git-annex/Makefile
index 810593edf12c..3a2a27eb2117 100644
--- a/devel/hs-git-annex/Makefile
+++ b/devel/hs-git-annex/Makefile
@@ -16,10 +16,11 @@ USE_CABAL= bloomfilter dataenc dlist edit-distance extensible-exceptions \
monad-control mtl>=2 network>=2.0 QuickCheck>=2.1 random \
SafeSemaphore SHA text unix-compat utf8-string uuid
-USE_GMAKE= yes
-USES= perl5
+USES= gmake perl5
USE_PERL5= build
+MAN1= git-annex.1 git-annex-shell.1
+
BUILD_DEPENDS+= rsync:${PORTSDIR}/net/rsync \
git:${PORTSDIR}/devel/git \
gsha256sum:${PORTSDIR}/sysutils/coreutils
@@ -42,7 +43,6 @@ PAIRING_DESC= Enable pairing (requires web application)
PRODUCTION_DESC= Production build
TDFA_DESC= Use regex-tdfa for wildcards
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.if ${PORT_OPTIONS:MS3}
diff --git a/devel/hs-git-annex/files/patch-Setup.hs b/devel/hs-git-annex/files/patch-Setup.hs
new file mode 100644
index 000000000000..7f82bdb2d34a
--- /dev/null
+++ b/devel/hs-git-annex/files/patch-Setup.hs
@@ -0,0 +1,35 @@
+--- Setup.hs.orig 2013-08-27 21:23:35.000000000 +0100
++++ Setup.hs 2013-12-08 17:28:34.656382191 +0000
+@@ -19,6 +19,7 @@
+ main = defaultMainWithHooks simpleUserHooks
+ { preConf = configure
+ , postInst = myPostInst
++ , postCopy = myPostCopy
+ }
+
+ configure _ _ = do
+@@ -34,6 +35,15 @@
+ dest = NoCopyDest
+ verbosity = fromFlag installVerbosity
+
++myPostCopy :: Args -> CopyFlags -> PackageDescription -> LocalBuildInfo -> IO ()
++myPostCopy _ (CopyFlags { copyVerbosity, copyDest }) pkg lbi = do
++ installGitAnnexShell dest verbosity pkg lbi
++ installManpages dest verbosity pkg lbi
++ installDesktopFile dest verbosity pkg lbi
++ where
++ dest = fromFlag copyDest
++ verbosity = fromFlag copyVerbosity
++
+ installGitAnnexShell :: CopyDest -> Verbosity -> PackageDescription -> LocalBuildInfo -> IO ()
+ installGitAnnexShell copyDest verbosity pkg lbi =
+ rawSystemExit verbosity "ln"
+@@ -50,7 +60,7 @@
+ installManpages copyDest verbosity pkg lbi =
+ installOrdinaryFiles verbosity dstManDir =<< srcManpages
+ where
+- dstManDir = mandir (absoluteInstallDirs pkg lbi copyDest) </> "man1"
++ dstManDir = prefix (absoluteInstallDirs pkg lbi copyDest) </> "man" </> "man1"
+ srcManpages = zip (repeat srcManDir)
+ <$> filterM doesFileExist manpages
+ srcManDir = ""