aboutsummaryrefslogtreecommitdiffstats
path: root/devel/hs-git-annex
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-06-26 16:15:16 +0800
committermiwi <miwi@FreeBSD.org>2011-06-26 16:15:16 +0800
commitf957b23a85a20716ef2e7db1e55a068880be019a (patch)
treefd9a80124a6cf9fadb639ce19b7cbe62223dc976 /devel/hs-git-annex
parentf82f81bbbcb7b19ec15fb32f943a7166dd23c059 (diff)
downloadfreebsd-ports-gnome-f957b23a85a20716ef2e7db1e55a068880be019a.tar.gz
freebsd-ports-gnome-f957b23a85a20716ef2e7db1e55a068880be019a.tar.zst
freebsd-ports-gnome-f957b23a85a20716ef2e7db1e55a068880be019a.zip
git-annex allows managing files with git, without checking the file
contents into git. While that may seem paradoxical, it is useful when dealing with files larger than git can currently easily handle, whether due to limitations in memory, checksumming time, or disk space. Even without file content tracking, being able to manage files with git, move files around and delete files with versioned directory trees, and use branches and distributed clones, are all very handy reasons to use git. And annexed files can co-exist in the same git repository with regularly versioned files, which is convenient for maintaining documents, Makefiles, etc that are associated with annexed files but that benefit from full revision control. WWW: http://git-annex.branchable.com/ PR: ports/157077 Submitted by: frase at frase.id.au
Diffstat (limited to 'devel/hs-git-annex')
-rw-r--r--devel/hs-git-annex/Makefile41
-rw-r--r--devel/hs-git-annex/distinfo2
-rw-r--r--devel/hs-git-annex/files/patch-Makefile47
-rw-r--r--devel/hs-git-annex/pkg-descr14
4 files changed, 104 insertions, 0 deletions
diff --git a/devel/hs-git-annex/Makefile b/devel/hs-git-annex/Makefile
new file mode 100644
index 000000000000..033f99e12bef
--- /dev/null
+++ b/devel/hs-git-annex/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: git-annex
+# Date created: 8 June 2011
+# Whom: frase@frase.id.au
+#
+# $FreeBSD$
+#
+
+PORTNAME= git-annex
+PORTVERSION= 0.20110601
+CATEGORIES= devel haskell
+MASTER_SITES= http://git.kitenet.net/?p=git-annex.git;a=snapshot;sf=tgz;h=refs/tags/
+DISTFILES= ${PORTVERSION}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= frase@frase.id.au
+COMMENT= Manage file hierarchies with git
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
+ hs-MissingH>=0:${PORTSDIR}/devel/hs-MissingH \
+ hs-pcre-light>=0:${PORTSDIR}/devel/hs-pcre-light \
+ hs-utf8-string>=0:${PORTSDIR}/devel/hs-utf8-string \
+ hs-SHA>=0:${PORTSDIR}/security/hs-SHA \
+ hs-dataenc>=0:${PORTSDIR}/converters/hs-dataenc
+RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
+ hs-MissingH>=0:${PORTSDIR}/devel/hs-MissingH \
+ hs-pcre-light>=0:${PORTSDIR}/devel/hs-pcre-light \
+ hs-utf8-string>=0:${PORTSDIR}/devel/hs-utf8-string \
+ hs-SHA>=0:${PORTSDIR}/security/hs-SHA \
+ hs-dataenc>=0:${PORTSDIR}/converters/hs-dataenc
+
+USE_PERL5= yes
+USE_GMAKE= yes
+
+MAN1= git-annex.1 git-annex-shell.1
+
+LICENSE= GPLv3
+
+PLIST_FILES= bin/git-annex \
+ bin/git-annex-shell
+
+.include <bsd.port.mk>
diff --git a/devel/hs-git-annex/distinfo b/devel/hs-git-annex/distinfo
new file mode 100644
index 000000000000..edacae9e6724
--- /dev/null
+++ b/devel/hs-git-annex/distinfo
@@ -0,0 +1,2 @@
+SHA256 (git-annex/0.20110601) = 2718e5634a4384d8a2a284bac66f1cff76d2c048b6c57662c24c575a97e9193b
+SIZE (git-annex/0.20110601) = 358008
diff --git a/devel/hs-git-annex/files/patch-Makefile b/devel/hs-git-annex/files/patch-Makefile
new file mode 100644
index 000000000000..fee6be5c2660
--- /dev/null
+++ b/devel/hs-git-annex/files/patch-Makefile
@@ -0,0 +1,47 @@
+diff --git a/Makefile b/Makefile
+index 286c3a6..3ed7a59 100644
+--- Makefile
++++ Makefile
+@@ -1,4 +1,4 @@
+-PREFIX=/usr
++PREFIX=/usr/local
+ IGNORE=-ignore-package monads-fd
+ GHCFLAGS=-O2 -Wall $(IGNORE) -fspec-constr-count=5
+ ifdef PROFILE
+@@ -37,12 +37,8 @@ git-annex-shell.1: doc/git-annex-shell.mdwn
+ install: all
+ install -d $(DESTDIR)$(PREFIX)/bin
+ install $(bins) $(DESTDIR)$(PREFIX)/bin
+- install -d $(DESTDIR)$(PREFIX)/share/man/man1
+- install -m 0644 $(mans) $(DESTDIR)$(PREFIX)/share/man/man1
+- install -d $(DESTDIR)$(PREFIX)/share/doc/git-annex
+- if [ -d html ]; then \
+- rsync -a --delete html/ $(DESTDIR)$(PREFIX)/share/doc/git-annex/html/; \
+- fi
++ install -d $(DESTDIR)$(PREFIX)/man/man1
++ install -m 0644 $(mans) $(DESTDIR)$(PREFIX)/man/man1
+
+ test: $(bins)
+ if ! $(GHCMAKE) -O0 test; then \
+@@ -59,21 +55,7 @@ testcoverage: $(bins)
+ @hpc report test --exclude=Main --exclude=QC
+ @hpc markup test --exclude=Main --exclude=QC --destdir=.hpc >/dev/null
+
+-# If ikiwiki is available, build static html docs suitable for being
+-# shipped in the software package.
+-ifeq ($(shell which ikiwiki),)
+-IKIWIKI=@echo "** ikiwiki not found, skipping building docs" >&2; true
+-else
+-IKIWIKI=ikiwiki
+-endif
+-
+ docs: $(mans)
+- $(IKIWIKI) doc html -v --wikiname git-annex --plugin=goodstuff \
+- --no-usedirs --disable-plugin=openid --plugin=sidebar \
+- --underlaydir=/dev/null --disable-plugin=shortcut \
+- --disable-plugin=smiley \
+- --plugin=comments --set comments_pagespec="*" \
+- --exclude='news/.*'
+
+ clean:
+ rm -rf build $(bins) $(mans) test configure *.tix .hpc \
diff --git a/devel/hs-git-annex/pkg-descr b/devel/hs-git-annex/pkg-descr
new file mode 100644
index 000000000000..b950d65e9dc1
--- /dev/null
+++ b/devel/hs-git-annex/pkg-descr
@@ -0,0 +1,14 @@
+git-annex allows managing files with git, without checking the file
+contents into git. While that may seem paradoxical, it is useful when
+dealing with files larger than git can currently easily handle, whether
+due to limitations in memory, checksumming time, or disk space.
+
+Even without file content tracking, being able to manage files with git,
+move files around and delete files with versioned directory trees, and use
+branches and distributed clones, are all very handy reasons to use git.
+And annexed files can co-exist in the same git repository with regularly
+versioned files, which is convenient for maintaining documents, Makefiles,
+etc that are associated with annexed files but that benefit from full
+revision control.
+
+WWW: http://git-annex.branchable.com/