aboutsummaryrefslogtreecommitdiffstats
path: root/devel/hs-gtk2hs-buildtools
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-02-10 16:03:22 +0800
committertcberner <tcberner@FreeBSD.org>2018-02-10 16:03:22 +0800
commit347f1992f9efbc7f86322f4fdc44ef46077120b6 (patch)
tree595a1c21749cc18bad532e9f0d057b340bc9d7c3 /devel/hs-gtk2hs-buildtools
parent59ccc6de2fad4f99c2fc31778fcbcf89ddc82c71 (diff)
downloadfreebsd-ports-gnome-347f1992f9efbc7f86322f4fdc44ef46077120b6.tar.gz
freebsd-ports-gnome-347f1992f9efbc7f86322f4fdc44ef46077120b6.tar.zst
freebsd-ports-gnome-347f1992f9efbc7f86322f4fdc44ef46077120b6.zip
Switch C compiler used to compile GHC to base Clang.
This removes build dependency on gcc and runtime dependency on gcc's runtime libraries. Big thanks to Gleb for working on this. PR: 225185 Submitted by: Gleb Popov <6yearold@gmail.com> Exp-run by: antoine Reviewed by: pgj Differential Revision: https://reviews.freebsd.org/D12043
Diffstat (limited to 'devel/hs-gtk2hs-buildtools')
-rw-r--r--devel/hs-gtk2hs-buildtools/Makefile1
-rw-r--r--devel/hs-gtk2hs-buildtools/files/patch-c2hs_toplevel_C2HSConfig.hs4
2 files changed, 3 insertions, 2 deletions
diff --git a/devel/hs-gtk2hs-buildtools/Makefile b/devel/hs-gtk2hs-buildtools/Makefile
index 50c90a6be8ea..34d0177fc389 100644
--- a/devel/hs-gtk2hs-buildtools/Makefile
+++ b/devel/hs-gtk2hs-buildtools/Makefile
@@ -2,6 +2,7 @@
PORTNAME= gtk2hs-buildtools
PORTVERSION= 0.13.2.2
+PORTREVISION= 1
CATEGORIES= devel haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/devel/hs-gtk2hs-buildtools/files/patch-c2hs_toplevel_C2HSConfig.hs b/devel/hs-gtk2hs-buildtools/files/patch-c2hs_toplevel_C2HSConfig.hs
index 9c1fbee08541..64096448efc0 100644
--- a/devel/hs-gtk2hs-buildtools/files/patch-c2hs_toplevel_C2HSConfig.hs
+++ b/devel/hs-gtk2hs-buildtools/files/patch-c2hs_toplevel_C2HSConfig.hs
@@ -13,8 +13,8 @@ c2hs: C header contains errors:
("openbsd","cpp") -> ["-xc", "-w"]
- (_,"cpp") -> ["-x", "c", "-w"]
- (_,"gcc") -> ["-E", "-x", "c", "-w"]
-+ (_,"cpp") -> ["-x", "c", "-w", "-std=c99"]
-+ (_,"gcc") -> ["-E", "-x", "c", "-w", "-std=c99"]
++ (_,"cpp") -> ["-x", "c", "-w", "-std=c99", "-D_Nullable=", "-D_Nonnull="]
++ (_,"gcc") -> ["-E", "-x", "c", "-w", "-std=c99", "-D_Nullable", "-D_Nonnull="]
_ -> []
-- C preprocessor option for including only definitions (EXPORTED)