aboutsummaryrefslogtreecommitdiffstats
path: root/devel/hs-hashed-storage
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2010-05-16 03:06:57 +0800
committerpgj <pgj@FreeBSD.org>2010-05-16 03:06:57 +0800
commit7c0f8bd7ce96414bb1ef463f88091a101b5d44e0 (patch)
tree18514e7fd692067833fd3c3b28a8f4fd481d721e /devel/hs-hashed-storage
parent431998dc47d771344a1a078cb5d021e9ce812fc1 (diff)
downloadfreebsd-ports-gnome-7c0f8bd7ce96414bb1ef463f88091a101b5d44e0.tar.gz
freebsd-ports-gnome-7c0f8bd7ce96414bb1ef463f88091a101b5d44e0.tar.zst
freebsd-ports-gnome-7c0f8bd7ce96414bb1ef463f88091a101b5d44e0.zip
Support code for reading and manipulating hashed file storage (where
each file and directory is associated with a cryptographic hash, for corruption-resistant storage and fast comparisons). The supported storage formats include darcs hashed pristine, a plain filesystem tree and an indexed plain tree (where the index maintains hashes of the plain files and directories). WWW: http://hackage.haskell.org/package/hashed-storage
Diffstat (limited to 'devel/hs-hashed-storage')
-rw-r--r--devel/hs-hashed-storage/Makefile33
-rw-r--r--devel/hs-hashed-storage/distinfo3
-rw-r--r--devel/hs-hashed-storage/pkg-descr9
-rw-r--r--devel/hs-hashed-storage/pkg-plist28
4 files changed, 73 insertions, 0 deletions
diff --git a/devel/hs-hashed-storage/Makefile b/devel/hs-hashed-storage/Makefile
new file mode 100644
index 000000000000..deff1a5b20b6
--- /dev/null
+++ b/devel/hs-hashed-storage/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: hs-hashed-storage
+# Date created: May 14, 2010
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hashed-storage
+PORTVERSION= 0.5
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Hashed file storage support code
+
+CABAL_SETUP= Setup.hs
+
+USE_HACKAGE= binary dataenc mmap>=0.5 zlib
+
+OPTIONS= TEST "Build tests" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_TEST)
+CONFIGURE_ARGS+= --flags="test"
+EXECUTABLE+= hashed-storage-test
+PLIST_SUB+= MAYBE_TEST=""
+.else
+CONFIGURE_ARGS+= --flags="-test"
+PLIST_SUB+= MAYBE_TEST="@comment "
+.endif
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-hashed-storage/distinfo b/devel/hs-hashed-storage/distinfo
new file mode 100644
index 000000000000..03bce0acdff5
--- /dev/null
+++ b/devel/hs-hashed-storage/distinfo
@@ -0,0 +1,3 @@
+MD5 (hashed-storage-0.5.tar.gz) = 84eb0ee6838c909ea25100db91d3232b
+SHA256 (hashed-storage-0.5.tar.gz) = d73b621b2b2d10060b5f6ca2388a9f51d3874d77bd1740d3bea4858b471ac487
+SIZE (hashed-storage-0.5.tar.gz) = 55292
diff --git a/devel/hs-hashed-storage/pkg-descr b/devel/hs-hashed-storage/pkg-descr
new file mode 100644
index 000000000000..c6cf79de7361
--- /dev/null
+++ b/devel/hs-hashed-storage/pkg-descr
@@ -0,0 +1,9 @@
+Support code for reading and manipulating hashed file storage (where
+each file and directory is associated with a cryptographic hash, for
+corruption-resistant storage and fast comparisons).
+
+The supported storage formats include darcs hashed pristine, a plain
+filesystem tree and an indexed plain tree (where the index maintains
+hashes of the plain files and directories).
+
+WWW: http://hackage.haskell.org/package/hashed-storage
diff --git a/devel/hs-hashed-storage/pkg-plist b/devel/hs-hashed-storage/pkg-plist
new file mode 100644
index 000000000000..7fd117f25af6
--- /dev/null
+++ b/devel/hs-hashed-storage/pkg-plist
@@ -0,0 +1,28 @@
+@comment $FreeBSD$
+%%MAYBE_TEST%%bin/hashed-storage-test
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Bundled/Posix.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Bundled/SHA256.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/AnchoredPath.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Darcs.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Hash.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Index.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Monad.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Packed.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Plain.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Tree.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Utils.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
+%%LIBDIR_REL%%/register.sh
+%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
+%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Bundled
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%LIBDIR_REL%%
+@exec /bin/sh %D/%%LIBDIR_REL%%/register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister %%PORTNAME%%-%%PORTVERSION%%
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old