aboutsummaryrefslogtreecommitdiffstats
path: root/devel/hs-hashed-storage
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2011-05-09 13:28:57 +0800
committerashish <ashish@FreeBSD.org>2011-05-09 13:28:57 +0800
commitc7a47a981222b062ac48e4edc5cae32fbed2b9c7 (patch)
treea1af1f5739f0a44d179f6f44b2ea70e07401da25 /devel/hs-hashed-storage
parent63b87600f00dd6e3a998a1862f7c209aa5e62523 (diff)
downloadfreebsd-ports-gnome-c7a47a981222b062ac48e4edc5cae32fbed2b9c7.tar.gz
freebsd-ports-gnome-c7a47a981222b062ac48e4edc5cae32fbed2b9c7.tar.zst
freebsd-ports-gnome-c7a47a981222b062ac48e4edc5cae32fbed2b9c7.zip
- Please welcome GHC 7.0.3
GHC in the ports tree has been updated to 7.0.3 and all other Haskell ports are also updated to their corresponding Haskell Platform versions, or latest versions. We would like to acknowledge the support of the FreeBSD Donations Team and Eotvos Lorand University, Faculty of Informatics who contributed to the server that we used for testing. We would also like to thank all the testers who tested FreeBSD Haskell ports and provided their feedback. PR: ports/156642 Approved by: tabthorpe (mentor) Obtained from: FreeBSD Haskell
Diffstat (limited to 'devel/hs-hashed-storage')
-rw-r--r--devel/hs-hashed-storage/Makefile13
-rw-r--r--devel/hs-hashed-storage/distinfo5
-rw-r--r--devel/hs-hashed-storage/pkg-plist28
3 files changed, 9 insertions, 37 deletions
diff --git a/devel/hs-hashed-storage/Makefile b/devel/hs-hashed-storage/Makefile
index 01e8ce2c4993..803734df7607 100644
--- a/devel/hs-hashed-storage/Makefile
+++ b/devel/hs-hashed-storage/Makefile
@@ -6,15 +6,16 @@
#
PORTNAME= hashed-storage
-PORTVERSION= 0.5.2
+PORTVERSION= 0.5.5
CATEGORIES= devel haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Hashed file storage support code
-CABAL_SETUP= Setup.hs
+LICENSE= BSD
-USE_HACKAGE= binary dataenc mmap>=0.5 zlib
+CABAL_SETUP= Setup.hs
+USE_CABAL= binary dataenc mmap>=0.5 mtl zlib
OPTIONS= TEST "Build tests" off
@@ -23,12 +24,12 @@ OPTIONS= TEST "Build tests" off
.if defined(WITH_TEST)
CONFIGURE_ARGS+= --flags="test"
-USE_HACKAGE+= test-framework test-framework-hunit test-framework-quickcheck2 QuickCheck>=2.0.0.0 zip-archive
+USE_CABAL+= test-framework test-framework-hunit \
+ test-framework-quickcheck2 HUnit \
+ QuickCheck>=2.3 zip-archive
EXECUTABLE+= hashed-storage-test
-PLIST_SUB+= MAYBE_TEST=""
.else
CONFIGURE_ARGS+= --flags="-test"
-PLIST_SUB+= MAYBE_TEST="@comment "
.endif
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/devel/hs-hashed-storage/distinfo b/devel/hs-hashed-storage/distinfo
index 6e56ccf28845..0a4e0a5c5d4e 100644
--- a/devel/hs-hashed-storage/distinfo
+++ b/devel/hs-hashed-storage/distinfo
@@ -1,3 +1,2 @@
-MD5 (cabal/hashed-storage-0.5.2.tar.gz) = 9173f18fc672dab4e05d38092d5e7dc6
-SHA256 (cabal/hashed-storage-0.5.2.tar.gz) = 4277228f7ba67d3de35fdfbbc2772911f6c4e2a84951fcd98103644379e106dc
-SIZE (cabal/hashed-storage-0.5.2.tar.gz) = 55447
+SHA256 (cabal/hashed-storage-0.5.5.tar.gz) = 82206b4470af3c89afb5bfd912eaea5ae45bd0e3067d6716f2766efb66109d0f
+SIZE (cabal/hashed-storage-0.5.5.tar.gz) = 55919
diff --git a/devel/hs-hashed-storage/pkg-plist b/devel/hs-hashed-storage/pkg-plist
deleted file mode 100644
index 7fd117f25af6..000000000000
--- a/devel/hs-hashed-storage/pkg-plist
+++ /dev/null
@@ -1,28 +0,0 @@
-@comment $FreeBSD$
-%%MAYBE_TEST%%bin/hashed-storage-test
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Bundled/Posix.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Bundled/SHA256.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/AnchoredPath.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Darcs.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Hash.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Index.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Monad.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Packed.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Plain.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Tree.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Utils.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
-%%LIBDIR_REL%%/register.sh
-%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
-%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
-@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed
-@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage
-@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Bundled
-@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%
-@dirrm %%LIBDIR_REL%%
-@exec /bin/sh %D/%%LIBDIR_REL%%/register.sh
-@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
-@unexec %D/bin/ghc-pkg unregister %%PORTNAME%%-%%PORTVERSION%%
-@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old