aboutsummaryrefslogtreecommitdiffstats
path: root/devel/hs-idoc
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-06-04 04:52:29 +0800
committerpgj <pgj@FreeBSD.org>2012-06-04 04:52:29 +0800
commit0a710f368469e3e4eae0e43e8df218c8a9983268 (patch)
treef1130d11cb235986af009fc8b05aa63a6548dcdd /devel/hs-idoc
parentba25a6ecc79a73710fb284c6682d27fad65d1d0e (diff)
downloadfreebsd-ports-gnome-0a710f368469e3e4eae0e43e8df218c8a9983268.tar.gz
freebsd-ports-gnome-0a710f368469e3e4eae0e43e8df218c8a9983268.tar.zst
freebsd-ports-gnome-0a710f368469e3e4eae0e43e8df218c8a9983268.zip
- Update The Glorious Glasgow Haskell Compiler to version 7.4.1
Please note that port revision for all the Haskell ports without version changes are also bumped. Other per-port updates are coming soon (in separate commits)! In addition to that, separate -docs ports are no longer needed so they are now removed. Thanks ashish@ for the assistance. Obtained from: FreeBSD Haskell
Diffstat (limited to 'devel/hs-idoc')
-rw-r--r--devel/hs-idoc/Makefile2
-rw-r--r--devel/hs-idoc/files/patch-GetOpt.hs11
-rw-r--r--devel/hs-idoc/files/patch-IDoc.hs18
-rw-r--r--devel/hs-idoc/files/patch-Makefile4
4 files changed, 32 insertions, 3 deletions
diff --git a/devel/hs-idoc/Makefile b/devel/hs-idoc/Makefile
index 5483a13a7822..7660546f2074 100644
--- a/devel/hs-idoc/Makefile
+++ b/devel/hs-idoc/Makefile
@@ -6,7 +6,7 @@
PORTNAME= idoc
PORTVERSION= 0.2.6
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= devel haskell
MASTER_SITES= http://www.cse.unsw.edu.au/~chak/haskell/idoc/
PKGNAMEPREFIX= hs-
diff --git a/devel/hs-idoc/files/patch-GetOpt.hs b/devel/hs-idoc/files/patch-GetOpt.hs
new file mode 100644
index 000000000000..e364d58ac310
--- /dev/null
+++ b/devel/hs-idoc/files/patch-GetOpt.hs
@@ -0,0 +1,11 @@
+--- ./GetOpt.hs.orig 2002-02-18 01:54:06.000000000 +0100
++++ ./GetOpt.hs 2012-05-13 00:56:23.000000000 +0200
+@@ -19,7 +19,7 @@
+
+ module GetOpt (ArgOrder(..), OptDescr(..), ArgDescr(..), usageInfo, getOpt) where
+
+-import List(isPrefixOf)
++import Data.List(isPrefixOf)
+
+ data ArgOrder a -- what to do with options following non-options:
+ = RequireOrder -- no option processing after first non-option
diff --git a/devel/hs-idoc/files/patch-IDoc.hs b/devel/hs-idoc/files/patch-IDoc.hs
new file mode 100644
index 000000000000..52c3cd820aa8
--- /dev/null
+++ b/devel/hs-idoc/files/patch-IDoc.hs
@@ -0,0 +1,18 @@
+--- ./IDoc.hs.orig 2004-05-14 08:54:08.000000000 +0200
++++ ./IDoc.hs 2012-05-13 00:56:43.000000000 +0200
+@@ -181,10 +181,11 @@
+ where
+
+ -- standard libraries
+-import Char (isAlpha, isDigit, toUpper, isSpace, isDigit)
+-import List (isPrefixOf, intersperse)
+-import IO (stderr, hPutStr)
+-import System (ExitCode(..), getArgs, exitWith)
++import Data.Char (isAlpha, isDigit, toUpper, isSpace, isDigit)
++import Data.List (isPrefixOf, intersperse)
++import System.IO (stderr, hPutStr)
++import System.Environment (getArgs)
++import System.Exit (ExitCode(..), exitWith)
+
+ -- extra library
+ import GetOpt (ArgOrder(..), OptDescr(..), ArgDescr(..), usageInfo,
diff --git a/devel/hs-idoc/files/patch-Makefile b/devel/hs-idoc/files/patch-Makefile
index 27d4bf3f2d28..ef2238db6e60 100644
--- a/devel/hs-idoc/files/patch-Makefile
+++ b/devel/hs-idoc/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2002-02-28 07:33:03.000000000 +0100
-+++ Makefile 2011-03-26 12:47:27.290996479 +0100
+--- ./Makefile.orig 2002-02-28 07:33:03.000000000 +0100
++++ ./Makefile 2012-05-13 00:56:24.000000000 +0200
@@ -56,7 +56,6 @@
#
PACKAGE = idoc