aboutsummaryrefslogtreecommitdiffstats
path: root/devel/hs-monad-par
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2011-08-15 02:01:20 +0800
committerpgj <pgj@FreeBSD.org>2011-08-15 02:01:20 +0800
commit1f46c58b157641c72d71457acc8ac3520573b9b4 (patch)
tree12eb09fdff5c62310cb7508d8009ae30005e7cfd /devel/hs-monad-par
parent044086329ac7451ecde7d0e804c649e20541fe6c (diff)
downloadfreebsd-ports-gnome-1f46c58b157641c72d71457acc8ac3520573b9b4.tar.gz
freebsd-ports-gnome-1f46c58b157641c72d71457acc8ac3520573b9b4.tar.zst
freebsd-ports-gnome-1f46c58b157641c72d71457acc8ac3520573b9b4.zip
This library offers an alternative parallel programming API to that
provided by the parallel package. The Par monad allows the simple description of parallel computations, and can be used to add parallelism to pure Haskell code. The basic API is straightforward: the monad supports forking and simple communication in terms of IVars. The library comes with an efficient work-stealing implementation, but the internals are also exposed so that you can build your own scheduler if necessary. WWW: http://github.com/simonmar/monad-par Obtained from: FreeBSD Haskell
Diffstat (limited to 'devel/hs-monad-par')
-rw-r--r--devel/hs-monad-par/Makefile21
-rw-r--r--devel/hs-monad-par/distinfo2
-rw-r--r--devel/hs-monad-par/pkg-descr9
3 files changed, 32 insertions, 0 deletions
diff --git a/devel/hs-monad-par/Makefile b/devel/hs-monad-par/Makefile
new file mode 100644
index 000000000000..13fd6e20b372
--- /dev/null
+++ b/devel/hs-monad-par/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: hs-monad-par
+# Date created: July 30, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= monad-par
+PORTVERSION= 0.1.0.1
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= A library for parallel programming based on a monad
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= deepseq>=1.1 HUnit>=1.2
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-monad-par/distinfo b/devel/hs-monad-par/distinfo
new file mode 100644
index 000000000000..9554e6244266
--- /dev/null
+++ b/devel/hs-monad-par/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/monad-par-0.1.0.1.tar.gz) = b8e36410270edaf2016f255c7c4df6eb9c72440e05be8efee75284b813e0a569
+SIZE (cabal/monad-par-0.1.0.1.tar.gz) = 66527
diff --git a/devel/hs-monad-par/pkg-descr b/devel/hs-monad-par/pkg-descr
new file mode 100644
index 000000000000..ac17347d70d6
--- /dev/null
+++ b/devel/hs-monad-par/pkg-descr
@@ -0,0 +1,9 @@
+This library offers an alternative parallel programming API to that
+provided by the parallel package. The Par monad allows the simple
+description of parallel computations, and can be used to add parallelism
+to pure Haskell code. The basic API is straightforward: the monad
+supports forking and simple communication in terms of IVars. The library
+comes with an efficient work-stealing implementation, but the internals
+are also exposed so that you can build your own scheduler if necessary.
+
+WWW: http://github.com/simonmar/monad-par