aboutsummaryrefslogtreecommitdiffstats
path: root/devel/hs-monad-par
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-06-04 05:52:11 +0800
committerpgj <pgj@FreeBSD.org>2012-06-04 05:52:11 +0800
commit2c7bfb329fd697213d9f8d4ee536d8fc4a29d44a (patch)
tree359f4c304ca372127b7ceaa098bdf9b2750bb0de /devel/hs-monad-par
parent1de93e81f92f94e39c194e2658b431365510f728 (diff)
downloadfreebsd-ports-gnome-2c7bfb329fd697213d9f8d4ee536d8fc4a29d44a.tar.gz
freebsd-ports-gnome-2c7bfb329fd697213d9f8d4ee536d8fc4a29d44a.tar.zst
freebsd-ports-gnome-2c7bfb329fd697213d9f8d4ee536d8fc4a29d44a.zip
- Update to 0.3
Obtained from: FreeBSD Haskell
Diffstat (limited to 'devel/hs-monad-par')
-rw-r--r--devel/hs-monad-par/Makefile6
-rw-r--r--devel/hs-monad-par/distinfo4
-rw-r--r--devel/hs-monad-par/pkg-descr2
3 files changed, 7 insertions, 5 deletions
diff --git a/devel/hs-monad-par/Makefile b/devel/hs-monad-par/Makefile
index 44ea2e8a51b3..3ac2f1b7ad3a 100644
--- a/devel/hs-monad-par/Makefile
+++ b/devel/hs-monad-par/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= monad-par
-PORTVERSION= 0.1.0.3
+PORTVERSION= 0.3
CATEGORIES= devel haskell
MAINTAINER= haskell@FreeBSD.org
@@ -15,7 +15,9 @@ COMMENT= A library for parallel programming based on a monad
LICENSE= BSD
CABAL_SETUP= Setup.hs
-USE_CABAL= deepseq>=1.1 HUnit>=1.2
+
+USE_CABAL= abstract-deque>=0.1.4 abstract-par monad-par-extras \
+ mtl>=2.0.1.0 mwc-random>=0.11 parallel>=3.1
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/devel/hs-monad-par/distinfo b/devel/hs-monad-par/distinfo
index cffa03a2b350..ca091a9002ca 100644
--- a/devel/hs-monad-par/distinfo
+++ b/devel/hs-monad-par/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/monad-par-0.1.0.3.tar.gz) = af0a8d47f28f17b0bad59da803bfb5c3b4aa52556f69c10cd850944023651eb0
-SIZE (cabal/monad-par-0.1.0.3.tar.gz) = 66529
+SHA256 (cabal/monad-par-0.3.tar.gz) = 4dff74044354c05676c7d69454f3b11a4855eb8ebe92c5f223e8a30d31fa7fa7
+SIZE (cabal/monad-par-0.3.tar.gz) = 25388
diff --git a/devel/hs-monad-par/pkg-descr b/devel/hs-monad-par/pkg-descr
index ac17347d70d6..f9842e124919 100644
--- a/devel/hs-monad-par/pkg-descr
+++ b/devel/hs-monad-par/pkg-descr
@@ -1,5 +1,5 @@
This library offers an alternative parallel programming API to that
-provided by the parallel package. The Par monad allows the simple
+provided by the 'parallel' package. The Par monad allows the simple
description of parallel computations, and can be used to add parallelism
to pure Haskell code. The basic API is straightforward: the monad
supports forking and simple communication in terms of IVars. The library