aboutsummaryrefslogtreecommitdiffstats
path: root/devel/icu/Makefile
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2001-03-17 16:49:14 +0800
committerkuriyama <kuriyama@FreeBSD.org>2001-03-17 16:49:14 +0800
commit14573c55bbfc0d00f1850284f63e49c15799355a (patch)
tree1ab12403cc8239326dab94f6922221f849652727 /devel/icu/Makefile
parent601996d1983c1fd71fa6b82b36472518beaaa016 (diff)
downloadfreebsd-ports-gnome-14573c55bbfc0d00f1850284f63e49c15799355a.tar.gz
freebsd-ports-gnome-14573c55bbfc0d00f1850284f63e49c15799355a.tar.zst
freebsd-ports-gnome-14573c55bbfc0d00f1850284f63e49c15799355a.zip
Add icu 1.7, international Components for Unicode (from IBM).
PR: ports/24649 Submitted by: dwm@caimis.com
Diffstat (limited to 'devel/icu/Makefile')
-rw-r--r--devel/icu/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/icu/Makefile b/devel/icu/Makefile
new file mode 100644
index 000000000000..2dcca26ea931
--- /dev/null
+++ b/devel/icu/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: icu
+# Date created: 22 Jan 2001
+# Whom: dwm
+#
+# $FreeBSD$
+#
+
+PORTNAME= icu
+PORTVERSION= 1.7
+CATEGORIES= devel
+MASTER_SITES= http://oss.software.ibm.com/developerworks/opensource/icu/project/download/${PORTVERSION}/
+#DISTNAME= ${PORTNAME}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dwm@caimis.com
+
+WRKSRC= ${WRKDIR}/${PORTNAME}/source
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+CONFIGURE_ARGS+=--disable-shared --enable-static
+CONFIGURE_ENV= CXXFLAGS="-O3"
+CONFIGURE_ENV+= CFLAGS="-O3"
+
+.include <bsd.port.mk>