aboutsummaryrefslogtreecommitdiffstats
path: root/devel/icu
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2004-11-25 16:44:01 +0800
committermi <mi@FreeBSD.org>2004-11-25 16:44:01 +0800
commit40d2c3d671844fb4b4bab15ffec368c856048575 (patch)
treea6b96187f664f4384b30ace7b18bf0b1f580ecd9 /devel/icu
parent541c62e2e055c3dc239ac3beaaa47afa7a0804d7 (diff)
downloadfreebsd-ports-gnome-40d2c3d671844fb4b4bab15ffec368c856048575.tar.gz
freebsd-ports-gnome-40d2c3d671844fb4b4bab15ffec368c856048575.tar.zst
freebsd-ports-gnome-40d2c3d671844fb4b4bab15ffec368c856048575.zip
So this was not a fluke on my machine. intltest does hang more often,
than it does not and a thread-guru should take a closer look. Modify the port to make `intltest' part optional, while running through other vendor's tests. Vendor is notified -- http://www.jtcsv.com/cgibin/icu-bugs/incoming?id=1141 While here, change echo to ${ECHO}.
Diffstat (limited to 'devel/icu')
-rw-r--r--devel/icu/Makefile28
1 files changed, 21 insertions, 7 deletions
diff --git a/devel/icu/Makefile b/devel/icu/Makefile
index a7ffeede24c3..c13c83345f41 100644
--- a/devel/icu/Makefile
+++ b/devel/icu/Makefile
@@ -73,15 +73,29 @@ pre-patch:
# VPATH does not work due to IBM's mistake:
${LN} -s ${FILESDIR}/*.ucm ${WRKSRC}/source/data/mappings/
@for l in ${FILESDIR}/*.ucm ; do \
- echo UCM_SOURCE_LOCAL+=`basename $$l` >> \
+ ${ECHO} UCM_SOURCE_LOCAL+=`basename $$l` >> \
${WRKSRC}/source/data/mappings/ucmlocal.mk ; \
done
-post-build test:
- ${GMAKE} -C ${ICUWRKSRC}/test
-.for t in intltest iotest cintltst
- cd ${ICUWRKSRC}/test/$t && ${SETENV} \
- LD_LIBRARY_PATH=${ICUWRKSRC}/lib:${ICUWRKSRC}/tools/ctestfw ./$t
-.endfor
+iotest cintltst intltest:
+ -${GMAKE} -C ${ICUWRKSRC}/test
+ cd ${ICUWRKSRC}/test/${.TARGET} && ${SETENV} \
+ LD_LIBRARY_PATH=${ICUWRKSRC}/lib:${ICUWRKSRC}/tools/ctestfw \
+ ./${.TARGET}
+
+test: iotest cintltst intltest
+
+post-build: iotest cintltst
+ #
+ # Note, due to occasional hangs in one of the intltest's
+ # multi-threading subtests, the intltest is not part of automatic
+ # test in the current version of this port. This an unresolved
+ # problem so far:
+ # http://www.jtcsv.com/cgibin/icu-bugs/incoming?id=1141
+ #
+ # If you wish to help resolving it, try
+ #
+ # `make intltest' manually.
+ #
.include <bsd.port.mk>