aboutsummaryrefslogtreecommitdiffstats
path: root/devel/idlefork
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-09-22 19:56:23 +0800
committersobomax <sobomax@FreeBSD.org>2000-09-22 19:56:23 +0800
commit93d07ed23dfd9f33e80f36209a19f6f174fb79a3 (patch)
treefce5533451a172134642b1f8609a7fccdbedfb13 /devel/idlefork
parent9a3f0edd65a527cbaa3d789ff955ad2891c36980 (diff)
downloadfreebsd-ports-gnome-93d07ed23dfd9f33e80f36209a19f6f174fb79a3.tar.gz
freebsd-ports-gnome-93d07ed23dfd9f33e80f36209a19f6f174fb79a3.tar.zst
freebsd-ports-gnome-93d07ed23dfd9f33e80f36209a19f6f174fb79a3.zip
Pythonize.
Diffstat (limited to 'devel/idlefork')
-rw-r--r--devel/idlefork/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/devel/idlefork/Makefile b/devel/idlefork/Makefile
index 9b9f244119ba..7f72618b4bf2 100644
--- a/devel/idlefork/Makefile
+++ b/devel/idlefork/Makefile
@@ -13,19 +13,20 @@ EXTRACT_SUFX= .tgz
MAINTAINER= sobomax@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/bin/python:${PORTSDIR}/lang/python
-RUN_DEPENDS= ${LOCALBASE}/lib/python1.5/site-packages/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+RUN_DEPENDS= ${PYTHON_LIBDIR}/site-packages/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+
+USE_PYTHON= yes
+PYTHON_VERSION= python1.5
do-build:
- ${LOCALBASE}/bin/python \
- ${LOCALBASE}/lib/python1.5/compileall.py ${WRKSRC}
+ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
do-install:
@${MKDIR} ${PREFIX}/share/idle/Icons
@cd ${WRKSRC} && \
${INSTALL_DATA} *.py? help.txt ${PREFIX}/share/idle
@${INSTALL_DATA} ${WRKSRC}/Icons/* ${PREFIX}/share/idle/Icons
- @printf "#!/bin/sh\n${LOCALBASE}/bin/python ${PREFIX}/share/idle/idle.pyc\n" \
+ @printf "#!/bin/sh\n${PYTHON_CMD} ${PREFIX}/share/idle/idle.pyc\n" \
> ${WRKDIR}/idle.sh
@${INSTALL_SCRIPT} ${WRKDIR}/idle.sh ${PREFIX}/bin/idle
.if !defined(NOPORTDOCS)
amp;id=c8e830f3ce9dce2ac7700684716f6840159552fb'>Jettison SSLv2 support. Not only does this allow mail/mailx tocy2018-10-153-1/+31 * mail/dovecot: don't pick up libsodium if installed.ler2018-10-141-1/+3 * mail/pecl-mailparse: Fix build with PHP 7.3dbaio2018-10-142-1/+81 * lang/rust: update to 1.29.2jbeich2018-10-131-0/+1 * Fix mail/opendkim to work with standard sendmail in baseuqs2018-10-122-14/+21 * Deprecate most glib12 consumersantoine2018-10-124-15/+8 * Those ports are not compatible with php 7.3antoine2018-10-121-1/+1 * mail/qmailadmin: Chase cracklib dictionary rename from r408137tobik2018-10-112-3/+3 * Take maintainershipsunpoet2018-10-111-1/+1 * - Update devel/courier-unicode to 2.1madpilot2018-10-108-32/+38 * Update to 0.903sunpoet2018-10-103-3/+12 * Update to 2.201sunpoet2018-10-102-7/+15 * - fix OpenSSL 1.1.x builddinoex2018-10-101-1/+1 * - fix OpenSSL 1.1.x builddinoex2018-10-101-0/+11 * - Update to 0.26wen2018-10-093-4/+8 * - Update to 1.3.0wen2018-10-094-6/+11 * Fix some PKGNAME collisionsantoine2018-10-083-3/+3 * Connect all the PHP 7.3 portstz2018-10-081-0/+1 * Add PHP 7.3 RC2 to the ports-tree.tz2018-10-082-0/+53 * Use https to fetch from cyrusimap.org.ume2018-10-082-3/+3 * Update to 2.5.12.ume2018-10-084-23/+13 * mail/msmtp: update to 1.8.0novel2018-10-063-7/+11 * Fix every instance of RUN_DEPENDS:=${BUILD_DEPENDS} in p5 ports, exceptdes2018-10-0674-148/+148 * - Update to 3.3.4wen2018-10-033-186/+765 * Reset maintainership for roundcube related portsfeld2018-10-032-2/+2 * Remove expired ports:rene2018-10-032-16/+0 * Add explicit USES=pythonantoine2018-10-021-1/+1 * mail/dovecot upgrade to 2.3.3, mail/dovecot-pigeonhole upgrade to 0.5.3.ler2018-10-026-10/+20 * mail/thunderbird: update to 60.2.1 (rc1)cmt2018-10-024-127/+124 * gecko: switch to clang70jbeich2018-10-021-1/+1 * - Add LICENSEamdmi32018-10-012-9/+12 * The FreeBSD GNOME team proudly presents GNOME 3.28 for FreeBSD.kwm2018-09-3016-279/+355 * mail/mpop: sort _DEFAULT after r480920jbeich2018-09-301-1/+1 * mail/mpop: update to 1.4.0jbeich2018-09-302-5/+5 * mail/mpop: update to 1.2.8jbeich2018-09-302-5/+4 * mail/mpop: switch to GNUTLS by defaultjbeich2018-09-301-1/+2 * mail/mpop: chase new homejbeich2018-09-302-2/+2 * Bump PORTREVISION to chase update of multimedia/v4l_compat and libv4lriggs2018-09-291-1/+1 * lang/rust: update to 1.29.1jbeich2018-09-291-0/+1 * Fix build on gcc-based archs.linimon2018-09-281-1/+2 * - Update to 1.8.0vsevolod2018-09-284-24/+18 * mail/spamassassin: Update to 3.4.2zeising2018-09-2710-455/+36 * Update Objective-C LLVM version to 6.0.brooks2018-09-264-4/+4 * Fix error messages on tier-2 archs.linimon2018-09-261-3/+3 * - Update WWWamdmi32018-09-251-1/+1 * Update to upstream version 4.8.6riggs2018-09-223-15/+17 * - Update WWWamdmi32018-09-221-1/+1 * Add missing patchvsevolod2018-09-212-0/+45 * Fix build on gcc-bases archs.linimon2018-09-211-1/+1 * - Add more rcorder conditions [2]vsevolod2018-09-213-10/+11 * Update to 1.8.0.a1.20180920vsevolod2018-09-215-187/+202 * Bump PORTREVISION for changed CFLAGSemaste2018-09-191-1/+1 * dns/unbound: update to 1.8.0swills2018-09-191-1/+1 * mail/eps: add -fPIC on i386, to allow linking with lldemaste2018-09-191-0/+1 * Conditionalize EXIM_WARN_FLAGS on clang to fix build on gcc-basedlinimon2018-09-181-5/+10 * More precisely specify USES=compiler to fix build on gcc-basedlinimon2018-09-182-3/+4 * mail/postfixadmin: Add missing dependency, Fix packaging failure with DOCS op...ler2018-09-183-16/+20 * - Update to 1.9.1wen2018-09-173-11/+17 * Remove expired ports:rene2018-09-1619-409/+0 * lang/rust: Update to 1.29.0dumbbell2018-09-161-0/+41 * mail/thunderbird: update to 60.1.0jbeich2018-09-136-130/+131 * Update to 1.202sunpoet2018-09-132-9/+10 * Change x11/xorgproto to become a build depzeising2018-09-121-1/+1 * Update to 5.1.1crees2018-09-114-12/+15 * mail/nextcloud-mail: Update to 0.10.0brnrd2018-09-113-7/+8 * Revert r479294 - relocation of existing conf files violates POLAwoodsb022018-09-112-2/+2 * Add IPV6 option to ports using it but not defining it.mat2018-09-101-1/+1 * Add EXAMPLES options to ports that should have one.mat2018-09-104-2/+6 * Add DOCS options to ports that should have one.mat2018-09-1018-7/+31 * After an include, PLIST_SUB must be appended to, not overwritten.mat2018-09-102-2/+2 * Reassign all of tobez@'s p5 ports to perl@.des2018-09-108-8/+8 * - Update `mail/clawsker' to version 1.2.0danfe2018-09-102-5/+5 * mail/mailman: Use .conf suffix for /usr/local/etc/newsyslog.conf.d/woodsb022018-09-102-1/+2 * - add new port postfix-ldap-saslohauer2018-09-092-0/+15 * - update to 3.4-20180904ohauer2018-09-092-4/+4 * mail/roundcube-carddav: update to 3.0.2gahr2018-09-055-72/+10 * - Add LICENSEamdmi32018-09-051-0/+5 * Update to 3.2joneum2018-09-054-284/+308 * Update to 4.23.0sunpoet2018-09-023-5/+8 * - Update WWWamdmi32018-08-281-1/+1 * Update to 4.2.23joneum2018-08-282-4/+4 * - Update WWWamdmi32018-08-271-1/+1 * - Fix buildacm2018-08-272-1/+11 * - Update WWWamdmi32018-08-261-1/+1 * mail/exim: Stop using arc4random_stir.delphij2018-08-262-1/+18 * update to 5.9.3oliver2018-08-262-5/+4 * - update to 3.4-20180819.ohauer2018-08-212-4/+4 * Remove expired slave ports.rene2018-08-212-15/+0 * Remove expired ports:rene2018-08-2123-793/+0 * [NEW PORT]: mail/mblaze: Unix utilities to deal with Maildirloader2018-08-206-0/+126 * mail/dovecot, mail/dovecot22: suppress harmless error message when the symlin...ler2018-08-204-3/+4 * Update MAINTAINER: use @FreeBSD.orgsunpoet2018-08-191-1/+1 * Remove expired ports:rene2018-08-176-261/+0 * - Update to 2.6.34miwi2018-08-163-95/+68 * - make portlint happierdinoex2018-08-1611-46/+46 * - fix build for FreeBSD 11.2 and FreeBSD 12.0dinoex2018-08-161-0/+1 * Update to 1.0.1sunpoet2018-08-152-4/+4 * Deprecate mail/annoyance-filtertobik2018-08-141-0/+3 * mail/spamprobe: Fix build with Clang/libc++tobik2018-08-142-2/+12 * Deprecate mail/pop3vscantobik2018-08-141-0/+3 * [NEW PORT]: mail/managesieve3: Implements an RFC-5804 Manage Sieve clientloader2018-08-144-0/+31 * Flag more ports not compatible to PHP 7.x with IGNORE_WITH_PHPtz2018-08-131-1/+1 * mail/bincimap: Fix build with Clang 6.0.0loader2018-08-112-1/+18 * Update to 3.0.8.ume2018-08-102-5/+5 * Update to 1.3.7 release.ale2018-08-092-4/+4 * Regular sorting of categories Makefiles.mat2018-08-081-1/+1 * mail/rainloop mail/rainloop-community: Update to 1.12.1joneum2018-08-065-155/+7 * www/nextcloud-mail: Update to 0.8.3brnrd2018-08-052-4/+4 * Update MASTER_SITESsunpoet2018-08-051-1/+1 * Update Rspamd to 1.7.9vsevolod2018-08-043-5/+5 * mail/py-dkimpy: update to 0.8.1swills2018-08-042-4/+4 * Update to 0.6.72sunpoet2018-08-032-4/+4 * mail/mutt-lite: Deprecate and expire mail/mutt-litebhughes2018-08-021-0/+2 * mail/thunderbird: switch to rc4jbeich2018-08-024-101/+101 * Update to 3.4.0sunpoet2018-08-012-4/+4 * mail/roundcube-contextmenu: unbreak: upstream distsite moved inside githubpi2018-08-012-4/+4 * mail/roundcube-thunderbird_labels: unbreak: distsite moved inside githubpi2018-08-012-4/+4 * Security upgrade Mailman to 2.1.29mandree2018-07-312-9/+9 * - Update WWWamdmi32018-07-311-1/+1 * - Update WWWamdmi32018-07-301-1/+1 * Bump PORTREVISION for ports depending on the canonical version of GCCgerald2018-07-3016-11/+16 * mail/mew: update 6.7 -> 6.8pi2018-07-305-23/+12 * - Update WWWamdmi32018-07-291-1/+1 * - Update WWWamdmi32018-07-281-1/+1 * New port: mail/roundcube-yubikey_authpi2018-07-275-0/+72 * mail/py-afew: support both Python 2 and 3swills2018-07-271-2/+2 * mail/thunderbird: switch to rc3jbeich2018-07-254-90/+92 * - Update WWWamdmi32018-07-251-1/+1 * PHP 7.1 and PHP 7.2: add TEST_TARGET to all extensionstz2018-07-242-0/+4 * - Set DEPRECATED and EXPIRATION_DATEwen2018-07-241-0/+3 * - Pet portlintamdmi32018-07-232-2/+2 * - Update WWWamdmi32018-07-221-1/+1 * - Update WWWamdmi32018-07-211-1/+1 * mail/trojita: add USES=localbasetcberner2018-07-211-1/+2 * mail/qmail-dk: Fix build with lldtobik2018-07-202-2/+31 * mail/mutt: update to 1.10.1fernape2018-07-192-5/+4 * mail/thunderbird: update to 60.0jbeich2018-07-1938-154/+37304 * mail/thunderbird: drop patches in preparation for updatejbeich2018-07-1927-17154/+0 * mail/sieve-connect: Update 0.88 -> 0.89yuri2018-07-193-7/+7 * Reset maintainership of the ports maintained by alexey@renatasystems.orgyuri2018-07-195-5/+5 * mail/py-fuglu: Update to 0.8.0swills2018-07-192-6/+8 * mail/p5-Email-MessageID: remove dependency on p5-Email-Addresspi2018-07-181-3/+1 * - Update to 4.22.7wen2018-07-172-4/+4 * - Update WWWamdmi32018-07-171-1/+1 * Update to 20180716bapt2018-07-172-4/+4 * Remove expired ports:rene2018-07-1713-117/+0 * mail/spampd: Update to 2.51 and refine rc scriptgrembo2018-07-164-18/+11