aboutsummaryrefslogtreecommitdiffstats
path: root/devel/invitation_to_ruby
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2002-08-29 11:21:04 +0800
committeralane <alane@FreeBSD.org>2002-08-29 11:21:04 +0800
commit0ef35a34d646ce08c67dddae08670a317a6efa21 (patch)
treeb83efc2e4b75ca893e9a64e300c85edc3867e007 /devel/invitation_to_ruby
parente7aa292f67e8f0942bc15f241c84b86466e8a147 (diff)
downloadfreebsd-ports-gnome-0ef35a34d646ce08c67dddae08670a317a6efa21.tar.gz
freebsd-ports-gnome-0ef35a34d646ce08c67dddae08670a317a6efa21.tar.zst
freebsd-ports-gnome-0ef35a34d646ce08c67dddae08670a317a6efa21.zip
New port: invitation_to_ruby
A very introductory view of Ruby, for someone who's not used it before. Since there was no license on the web pages, I got explicit permission via email from the author to include it in ports.
Diffstat (limited to 'devel/invitation_to_ruby')
-rw-r--r--devel/invitation_to_ruby/Makefile53
-rw-r--r--devel/invitation_to_ruby/distinfo1
-rw-r--r--devel/invitation_to_ruby/pkg-comment1
-rw-r--r--devel/invitation_to_ruby/pkg-descr1
-rw-r--r--devel/invitation_to_ruby/pkg-plist1
5 files changed, 57 insertions, 0 deletions
diff --git a/devel/invitation_to_ruby/Makefile b/devel/invitation_to_ruby/Makefile
new file mode 100644
index 000000000000..922dc05c1a16
--- /dev/null
+++ b/devel/invitation_to_ruby/Makefile
@@ -0,0 +1,53 @@
+# ex:ts=8
+#
+# New ports collection makefile for: invitation_to_ruby
+# Date created: 2002/08/28
+# Whom: Alan Eldridge <ports@geeksrus.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= invitation_to_ruby
+PORTVERSION= 1.0.0
+#PORTEPOCH=
+CATEGORIES= devel
+MASTER_SITES= http://w3.one.net/~jweirich/development/talks/
+#MASTER_SITE_SUBDIR=
+#PKGNAMEPREFIX=
+#PKGNAMESUFFIX=
+DISTNAME= invitationtoruby
+EXTRACT_SUFX= .tgz
+#DISTFILES=
+#DIST_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
+#EXTRACT_ONLY=
+
+MAINTAINER= ports@geeksrus.net
+
+NO_BUILD= yes
+
+PLIST= ${WRKDIR}/plist
+
+CPIO?= /usr/bin/cpio
+SORT?= /usr/bin/sort
+
+.include <bsd.port.pre.mk>
+
+pre-install:
+ ${RM} -f ${PLIST}
+ ${ECHO_CMD} "@comment files" >> ${PLIST}
+ cd ${WRKSRC}; ${FIND} . -type f | cut -c2- \
+ | ${SED} 's|^|${DOCSDIR:S,${PREFIX}/,,}|' \
+ | ${SORT} >> ${PLIST}
+ ${ECHO_CMD} "@comment directories" >> ${PLIST}
+ cd ${WRKSRC}; ${FIND} . -type d | cut -c2- \
+ | ${SED} 's|^|@dirrm ${DOCSDIR:S,${PREFIX}/,,}|' \
+ | ${SORT} -r >> ${PLIST}
+
+do-install:
+ ${RM} -fr ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}; find . | ${CPIO} -pdmv -R ${DOCOWN}:${DOCGRP} ${DOCSDIR}
+ ${CHMOD} -R ugo-w,ugo+rX ${DOCSDIR}
+
+.include <bsd.port.post.mk>
+#EOF
diff --git a/devel/invitation_to_ruby/distinfo b/devel/invitation_to_ruby/distinfo
new file mode 100644
index 000000000000..1f6b06c26798
--- /dev/null
+++ b/devel/invitation_to_ruby/distinfo
@@ -0,0 +1 @@
+MD5 (invitationtoruby.tgz) = 2e44bef705ebccdd97de49a76875e0da
diff --git a/devel/invitation_to_ruby/pkg-comment b/devel/invitation_to_ruby/pkg-comment
new file mode 100644
index 000000000000..c7b40cf418c2
--- /dev/null
+++ b/devel/invitation_to_ruby/pkg-comment
@@ -0,0 +1 @@
+A talk given by Jim Weirich, a brief introduction to Ruby
diff --git a/devel/invitation_to_ruby/pkg-descr b/devel/invitation_to_ruby/pkg-descr
new file mode 100644
index 000000000000..9a751acb46f2
--- /dev/null
+++ b/devel/invitation_to_ruby/pkg-descr
@@ -0,0 +1 @@
+A talk given by Jim Weirich, a brief introduction to Ruby.
diff --git a/devel/invitation_to_ruby/pkg-plist b/devel/invitation_to_ruby/pkg-plist
new file mode 100644
index 000000000000..03bd588623a5
--- /dev/null
+++ b/devel/invitation_to_ruby/pkg-plist
@@ -0,0 +1 @@
+@comment The package list is generated by the Makefile.