aboutsummaryrefslogtreecommitdiffstats
path: root/devel/itext/Makefile
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2005-10-03 21:35:23 +0800
committerhq <hq@FreeBSD.org>2005-10-03 21:35:23 +0800
commit701f289a2408423945c99ce7fc6e78b6b66bfbe4 (patch)
tree0c259edd8dd6a3bc504d19496acf5510dad89809 /devel/itext/Makefile
parent2898afbcbd0ae151d8b1c9e4f95b398c72e8aa24 (diff)
downloadfreebsd-ports-gnome-701f289a2408423945c99ce7fc6e78b6b66bfbe4.tar.gz
freebsd-ports-gnome-701f289a2408423945c99ce7fc6e78b6b66bfbe4.tar.zst
freebsd-ports-gnome-701f289a2408423945c99ce7fc6e78b6b66bfbe4.zip
- Build classes/JAR file from source instead of downloading the JAR file
- Generate and install API documentation from source, too - Bump PORTREVISION as new files are installed PR: 86597 Submitted by: maintainer
Diffstat (limited to 'devel/itext/Makefile')
-rw-r--r--devel/itext/Makefile22
1 files changed, 17 insertions, 5 deletions
diff --git a/devel/itext/Makefile b/devel/itext/Makefile
index 81839472b9ff..3cbe52b8267d 100644
--- a/devel/itext/Makefile
+++ b/devel/itext/Makefile
@@ -8,24 +8,36 @@
PORTNAME= itext
PORTVERSION= 1.3.4
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel java
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-${PORTVERSION}
-EXTRACT_SUFX= .jar
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
MAINTAINER= sw@gegenunendlich.de
COMMENT= A Java-PDF Library
+WRKSRC= ${WRKDIR}/src
+EXTRACT_AFTER_ARGS= | (${MKDIR} ${WRKSRC} && ${TAR} -xf - -C ${WRKSRC})
USE_JAVA= yes
JAVA_VERSION= 1.2+
-NO_BUILD= yes
-EXTRACT_ONLY= # empty
+USE_ANT= yes
+ALL_TARGET= jar
+.if !defined(NOPORTDOCS)
+ALL_TARGET+= javadoc
+PORTDOCS= *
+.endif
PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
do-install:
- ${INSTALL_DATA} ${_DISTDIR}/${DISTFILES} ${JAVAJARDIR}/${PORTNAME}.jar
+ @${INSTALL_DATA} ${WRKDIR}/build/bin/iText.jar \
+ ${JAVAJARDIR}/${PORTNAME}.jar
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}/apidocs
+ @${CP} -R ${WRKDIR}/build/docs/* ${DOCSDIR}/apidocs
+ @${CHOWN} -h -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}/apidocs
+.endif
.include <bsd.port.mk>