aboutsummaryrefslogtreecommitdiffstats
path: root/devel/javolution
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2007-09-22 15:43:42 +0800
committerale <ale@FreeBSD.org>2007-09-22 15:43:42 +0800
commit5b36b6f9889df068c941e2f33384655ec5cf0e11 (patch)
tree8a8c9f6e180234a9d0c86b9b3c630418933539ec /devel/javolution
parent190100ea279f5c5f449529b837602469bb07bf27 (diff)
downloadfreebsd-ports-gnome-5b36b6f9889df068c941e2f33384655ec5cf0e11.tar.gz
freebsd-ports-gnome-5b36b6f9889df068c941e2f33384655ec5cf0e11.tar.zst
freebsd-ports-gnome-5b36b6f9889df068c941e2f33384655ec5cf0e11.zip
Javolution is the Java solution for real-time and embedded systems.
Javolution real-time goals are simple: to make your application faster and more time predictable! That being accomplished through: * High performance and time-deterministic (real-time) util / lang / text / io / xml base classes. * Context programming in order to achieve true separation of concerns (logging, performance, etc). * A testing framework addressing not only unit tests but also performance and regression tests as well. * Straightforward and low-level parallel computing capabilities with ConcurrentContext. * Struct and Union base classes for direct interfacing with native applications (e.g. C/C++). * World's fastest and first hard real-time XML marshalling/unmarshalling facility. * Simple yet flexible configuration management of your application. WWW: http://javolution.org/
Diffstat (limited to 'devel/javolution')
-rw-r--r--devel/javolution/Makefile39
-rw-r--r--devel/javolution/distinfo3
-rw-r--r--devel/javolution/pkg-descr23
3 files changed, 65 insertions, 0 deletions
diff --git a/devel/javolution/Makefile b/devel/javolution/Makefile
new file mode 100644
index 000000000000..348040e9b34b
--- /dev/null
+++ b/devel/javolution/Makefile
@@ -0,0 +1,39 @@
+# Ports collection makefile for: javolution
+# Date created: 22 September 2007
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= javolution
+PORTVERSION= 5.2.4
+CATEGORIES= devel java
+MASTER_SITES= http://javolution.org/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-bin
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= A Java solution for real time and embedded systems
+
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/([0-9].[0-9]).[0-9]/\1/}
+
+PORTDOCS= *
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR file as ${JAVAJARDIR}/${PORTNAME}.jar..."
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ @${ECHO_MSG} " [DONE]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation..."
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC} && ${FIND} index.html api css doc \
+ | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR} > /dev/null 2>&1
+ @${ECHO_MSG} " [DONE]"
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/javolution/distinfo b/devel/javolution/distinfo
new file mode 100644
index 000000000000..576f9d5a51f1
--- /dev/null
+++ b/devel/javolution/distinfo
@@ -0,0 +1,3 @@
+MD5 (javolution-5.2.4-bin.zip) = 53b085ac010bf86355244c6501ca0ed7
+SHA256 (javolution-5.2.4-bin.zip) = 3cba0d4e375a2d373ef5b1b7781e1331b4a5be4b8a26252c778d0acb6ddd57b7
+SIZE (javolution-5.2.4-bin.zip) = 1016007
diff --git a/devel/javolution/pkg-descr b/devel/javolution/pkg-descr
new file mode 100644
index 000000000000..99f84baf58aa
--- /dev/null
+++ b/devel/javolution/pkg-descr
@@ -0,0 +1,23 @@
+Javolution is the Java solution for real-time and embedded systems.
+Javolution real-time goals are simple: to make your application
+faster and more time predictable!
+
+That being accomplished through:
+ * High performance and time-deterministic (real-time)
+ util / lang / text / io / xml base classes.
+ * Context programming in order to achieve true separation of
+ concerns (logging, performance, etc).
+ * A testing framework addressing not only unit tests but also
+ performance and regression tests as well.
+ * Straightforward and low-level parallel computing capabilities
+ with ConcurrentContext.
+ * Struct and Union base classes for direct interfacing with native
+ applications (e.g. C/C++).
+ * World's fastest and first hard real-time XML
+ marshalling/unmarshalling facility.
+ * Simple yet flexible configuration management of your application.
+
+WWW: http://javolution.org/
+
+- Alex Dupre
+ale@FreeBSD.org