aboutsummaryrefslogtreecommitdiffstats
path: root/devel/jline/Makefile
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2007-10-03 02:20:44 +0800
committeralepulver <alepulver@FreeBSD.org>2007-10-03 02:20:44 +0800
commit4f3b1f364019dd8903a36b1e17eca6e1904900a1 (patch)
tree43bd36d5f8eec27fdfe388804c249ff0369d2375 /devel/jline/Makefile
parent9f1f2b083bdee2087fc2a23e2888aef7aba2867b (diff)
downloadfreebsd-ports-gnome-4f3b1f364019dd8903a36b1e17eca6e1904900a1.tar.gz
freebsd-ports-gnome-4f3b1f364019dd8903a36b1e17eca6e1904900a1.tar.zst
freebsd-ports-gnome-4f3b1f364019dd8903a36b1e17eca6e1904900a1.zip
JLine is a Java library for handling console input. It is similar in
functionality to BSD editline and GNU readline. People familiar with the readline/editline capabilities for modern shells (such as bash and tcsh) will find most of the command editing features of JLine to be familiar. JLine is distributed under the BSD license, meaning that you are completely free to redistribute, modify, or sell it with almost no restrictions. API documentation can be found in the apidocs directory. You can use the jline.ConsoleRunner application to set up the system input stream and continue on the launch another program. For example, to use JLine as the input handler for the popular BeanShell console application, you can run: java jline.ConsoleRunner bsh.Interpreter WWW: http://jline.sourceforge.net/ PR: ports/116661 Submitted by: Martin Kammerhofer <mkamm at gmx.net>
Diffstat (limited to 'devel/jline/Makefile')
-rw-r--r--devel/jline/Makefile66
1 files changed, 66 insertions, 0 deletions
diff --git a/devel/jline/Makefile b/devel/jline/Makefile
new file mode 100644
index 000000000000..46b04e274915
--- /dev/null
+++ b/devel/jline/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: libreadline-java
+# Date created: 21 September 2007
+# Whom: Martin Kammerhofer <mkamm@gmx.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jline
+PORTVERSION= 0.9.91
+CATEGORIES= devel java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= mkamm@gmx.net
+COMMENT= JLine is a Java library for handling console input
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+USE_JAVA= yes
+USE_ZIP= yes
+OPTIONS= JLINEPATCH "Allow ConsoleRunner customized completion" OFF
+JLINEJAR= ${WRKSRC}/jline-${PORTVERSION}.jar
+
+.include <bsd.port.pre.mk>
+
+# Update jar archive with patched jline.ConsoleRunner class.
+do-build:
+.ifdef(WITH_JLINEPATCH)
+ ${JAVAC} -classpath ${JLINEJAR} \
+ ${WRKSRC}/src/src/main/java/jline/ConsoleRunner.java
+ ${JAR} uvf ${JLINEJAR} -C ${WRKSRC}/src/src/main/java \
+ jline/ConsoleRunner.class
+.endif
+
+do-install:
+ ${INSTALL_DATA} ${JLINEJAR} ${JAVAJARDIR}
+ ${LN} -nfs ${JAVAJARDIR}/jline-${PORTVERSION}.jar \
+ ${JAVAJARDIR}/jline.jar
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/apidocs ${WRKSRC}/examples ${DOCSDIR}
+ ${INSTALL_DATA} ${FILESDIR}/JLineCompleter.py ${DOCSDIR}/examples
+ ${INSTALL_DATA} ${FILESDIR}/jython.sh ${DOCSDIR}/examples
+.endif
+
+post-install:
+ @${SED} -e 's|%%JAVAJARDIR%%|${JAVAJARDIR}|g' -- \
+ ${.CURDIR}/pkg-message >${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
+
+# Next rule is for maintainer use only: Automatically (re)create the pkg-plist.
+plist:
+ @test -e ${CONFIGURE_COOKIE} || { \
+ ${ECHO_MSG} >&2 "do 'make configure' first!"; exit 64; }
+ ${ECHO_CMD} "%%JAVAJARDIR%%/jline-${PORTVERSION}.jar" >${PLIST}
+ ${ECHO_CMD} "%%JAVAJARDIR%%/jline.jar" >>${PLIST}
+ ( \
+ cd ${WRKSRC} || exit; \
+ ${FIND} ./apidocs ./examples -type f | ${SORT}; \
+ ${ECHO_CMD} "./examples/JLineCompleter.py"; \
+ ${ECHO_CMD} "./examples/jython.sh"; \
+ ${FIND} ./apidocs ./examples -type d | ${SORT} -r \
+ | ${SED} -e 's/^/@dirrm /'; \
+ ${ECHO_CMD} "@dirrm %%DOCSDIR%%" ; \
+ ) | ${SED} -e 's/\.\//%%DOCSDIR%%\//' -e 's/^/%%PORTDOCS%%/' >>${PLIST}
+
+.include <bsd.port.post.mk>