aboutsummaryrefslogtreecommitdiffstats
path: root/devel/jsap/Makefile
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2005-01-17 05:26:58 +0800
committerhq <hq@FreeBSD.org>2005-01-17 05:26:58 +0800
commitdff4ca299848116f928df4639b40ecccb16098e7 (patch)
treeed0fac89c49d35b9ead8ed6f1c6d7dea050bafdc /devel/jsap/Makefile
parentcba35a94cdea77ffd276f1655337cfc4d1a19775 (diff)
downloadfreebsd-ports-gnome-dff4ca299848116f928df4639b40ecccb16098e7.tar.gz
freebsd-ports-gnome-dff4ca299848116f928df4639b40ecccb16098e7.tar.zst
freebsd-ports-gnome-dff4ca299848116f928df4639b40ecccb16098e7.zip
JSAP: the Java-based Simple Argument Parser
JSAP parses your command line and instantiates objects of types you specify based upon that command line. If you configure JSAP to expect an Integer on the command line, and the user does not provide a String that can be converted to an Integer, JSAP will alert your program to the fact that there was a problem with the command line. If JSAP indicates that your command line was successfully parsed, you are guaranteed an Integer when you request that parameter's value from your program. There's a pretty big (and growing) list of return types supported by JSAP. WWW: http://http://www.martiansoftware.com/jsap/index.html
Diffstat (limited to 'devel/jsap/Makefile')
-rw-r--r--devel/jsap/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/devel/jsap/Makefile b/devel/jsap/Makefile
new file mode 100644
index 000000000000..4c20aab03900
--- /dev/null
+++ b/devel/jsap/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: jsap
+# Date created: 2005-01-16
+# Whom: Herve Quiroz <hq@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jsap
+DISTVERSION= 1.03a
+CATEGORIES= devel java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME:U}-${DISTVERSION}
+
+MAINTAINER= hq@FreeBSD.org
+COMMENT= Java package to parse command-line arguments
+
+USE_JAVA= yes
+JAVA_VERSION= 1.3+
+NO_BUILD= yes
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= ch01.html ch01s02.html ch02.html ch03.html ch03s02.html \
+ ch03s03.html ch03s04.html ch03s05.html ch03s06.html \
+ ch03s07.html ch04.html ch04s02.html ch04s03.html ch04s04.html \
+ ch04s05.html ch05.html ch06.html ch07.html ch08.html ch09.html \
+ ch10.html ch11.html ch12.html ch13.html ch14.html ch15.html \
+ index.html javadoc manual.css pr01.html
+.endif
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${PORTNAME}.jar..."
+ @${MKDIR} ${JAVAJARDIR}
+ @${INSTALL_DATA} ${WRKSRC}/lib/${DISTNAME:S,-,_,}.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ @${ECHO_MSG} " [ DONE ]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}/..."
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/doc/ \
+ && ${FIND} ${PORTDOCS} -type d -exec ${MKDIR} ${DOCSDIR}/{} \; \
+ && ${FIND} ${PORTDOCS} -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+
+.include <bsd.port.mk>