aboutsummaryrefslogtreecommitdiffstats
path: root/devel/kdevelop
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2004-03-10 03:41:12 +0800
committerlofi <lofi@FreeBSD.org>2004-03-10 03:41:12 +0800
commit344150edd9e7a3101f87e63d531bdae2b9dbb21f (patch)
treeaa2a54a33e5e6163905ac68a0a01153dd9038687 /devel/kdevelop
parent0bf4cb87335558d7d6c7a77212d01366ca69ca07 (diff)
downloadfreebsd-ports-gnome-344150edd9e7a3101f87e63d531bdae2b9dbb21f.tar.gz
freebsd-ports-gnome-344150edd9e7a3101f87e63d531bdae2b9dbb21f.tar.zst
freebsd-ports-gnome-344150edd9e7a3101f87e63d531bdae2b9dbb21f.zip
Update to KDE 3.2.1 / QT 3.3.1
Important changes: ================== KDE: - Audio/arts does not install artswrapper anymore, instead it is provided by audio/artswrapper. See UPDATING. - misc/kdeaddons3 is now a metaport with editors/kate-plugins editors/vimpart games/atlantikdesigner misc/kaddressbook-plugins misc/kfile-plugins misc/kicker-applets misc/knewsticker-scripts misc/konq-plugins misc/ksig misc/renamedlgplugins multimedia/noatun-plugins net/kontact-plugins as slave ports. - A number of KDE ports now uses OPTIONS do make various WITH_* options more visible. - Plist fixes - devel/kdevelop should be able to detect FreeBSD's autoconf/automake now for newly created projects. - kdebase will no longer remove previous KDM configurations. This won't take effect during the update from 3.2.0 to 3.2.1 (as deinstalling 3.2.0 will still remove the configuration), but subsequent updates will merge old configs. QT: - Previous versions of QT could be compiled with debugging-support enabled by defining DEBUG. This switch has been renamed to the more unambiguous WANT_QT_DEBUG (similar to WANT_KDE_DEBUG in the KDE ports).
Diffstat (limited to 'devel/kdevelop')
-rw-r--r--devel/kdevelop/Makefile28
-rw-r--r--devel/kdevelop/distinfo3
-rw-r--r--devel/kdevelop/files/patch-parts-appwizard-common-admin-detect-autoconf.sh31
-rw-r--r--devel/kdevelop/pkg-plist53
4 files changed, 73 insertions, 42 deletions
diff --git a/devel/kdevelop/Makefile b/devel/kdevelop/Makefile
index 719ce6219fbb..cd9d40c2d41f 100644
--- a/devel/kdevelop/Makefile
+++ b/devel/kdevelop/Makefile
@@ -6,24 +6,24 @@
#
PORTNAME= kdevelop
-PORTVERSION= 3.0.0
+PORTVERSION= 3.0.2
CATEGORIES?= devel kde
MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= stable/${KDE_VERSION:S/.0//}/src
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
# DISTNAME= ${KDE_DISTNAME}
DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
COMMENT= Powerful IDE for developing KDE/Qt-based apps
-BUILD_DEPENDS= msgfmt:${PORTSDIR}/devel/gettext
-LIB_DEPENDS= db41:${PORTSDIR}/databases/db41
+BUILD_DEPENDS= msgfmt:${PORTSDIR}/devel/gettext
+LIB_DEPENDS= db4:${PORTSDIR}/databases/db4
RUN_DEPENDS= extractrc:${PORTSDIR}/devel/kdesdk3 \
- gmake:${PORTSDIR}/devel/gmake
+ gmake:${PORTSDIR}/devel/gmake \
+ autoconf257:${PORTSDIR}/devel/autoconf257 \
+ automake17:${PORTSDIR}/devel/automake17
.if defined(WITH_OPTIONAL_DEPENDS)
-RUN_DEPENDS+= autoconf:${PORTSDIR}/devel/autoconf \
- automake:${PORTSDIR}/devel/automake \
- kiconedit:${PORTSDIR}/graphics/kdegraphics3 \
+RUN_DEPENDS+= kiconedit:${PORTSDIR}/graphics/kdegraphics3 \
ark:${PORTSDIR}/misc/kdeutils3 \
glimpse:${PORTSDIR}/textproc/glimpse \
a2ps:${PORTSDIR}/print/a2ps-letter
@@ -53,11 +53,11 @@ post-patch:
pre-configure:
${REINPLACE_CMD} -e 's@extractrc@@g' ${WRKSRC}/Makefile.in
- ${REINPLACE_CMD} -e 's@$$CXXFLAGS $$X_CFLAGS -ldb@-I/usr/local/include/db41 $$CXXFLAGS $$X_CFLAGS -L/usr/local/lib -ldb41@' ${WRKSRC}/configure
- ${REINPLACE_CMD} -e 's@INCLUDES = $$(all_includes)@INCLUDES = -I/usr/local/include/db41 $$(all_includes)@' ${WRKSRC}/lib/catalog/Makefile.in
- ${REINPLACE_CMD} -e 's@libkdevcatalog_la_LIBADD = -ldb@libkdevcatalog_la_LIBADD = -L/usr/local/lib -ldb41@' ${WRKSRC}/lib/catalog/Makefile.in
- ${REINPLACE_CMD} -e 's@^all_includes = @all_includes = -I/usr/local/include/db41 @' ${WRKSRC}/languages/cpp/Makefile.in
- ${REINPLACE_CMD} -e 's@^all_includes = @all_includes = -I/usr/local/include/db41 @' ${WRKSRC}/languages/java/Makefile.in
- ${REINPLACE_CMD} -e 's@^all_includes = @all_includes = -I/usr/local/include/db41 @' ${WRKSRC}/languages/pascal/Makefile.in
+ ${REINPLACE_CMD} -e 's@$$CXXFLAGS $$X_CFLAGS -ldb@-I/usr/local/include/db4 $$CXXFLAGS $$X_CFLAGS -L/usr/local/lib -ldb4@' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's@INCLUDES = $$(all_includes)@INCLUDES = -I/usr/local/include/db4 $$(all_includes)@' ${WRKSRC}/lib/catalog/Makefile.in
+ ${REINPLACE_CMD} -e 's@libkdevcatalog_la_LIBADD = -ldb@libkdevcatalog_la_LIBADD = -L/usr/local/lib -ldb4@' ${WRKSRC}/lib/catalog/Makefile.in
+ ${REINPLACE_CMD} -e 's@^all_includes = @all_includes = -I/usr/local/include/db4 @' ${WRKSRC}/languages/cpp/Makefile.in
+ ${REINPLACE_CMD} -e 's@^all_includes = @all_includes = -I/usr/local/include/db4 @' ${WRKSRC}/languages/java/Makefile.in
+ ${REINPLACE_CMD} -e 's@^all_includes = @all_includes = -I/usr/local/include/db4 @' ${WRKSRC}/languages/pascal/Makefile.in
.include <bsd.port.post.mk>
diff --git a/devel/kdevelop/distinfo b/devel/kdevelop/distinfo
index 0df7b8c9bda8..fb34a84bce1b 100644
--- a/devel/kdevelop/distinfo
+++ b/devel/kdevelop/distinfo
@@ -1 +1,2 @@
-MD5 (KDE/kdevelop-3.0.0.tar.bz2) = fa823d9fa2444938ecafb97949500c27
+MD5 (KDE/kdevelop-3.0.2.tar.bz2) = 1c7df5b7abfc1981922f8a681ab93bb0
+SIZE (KDE/kdevelop-3.0.2.tar.bz2) = 5531192
diff --git a/devel/kdevelop/files/patch-parts-appwizard-common-admin-detect-autoconf.sh b/devel/kdevelop/files/patch-parts-appwizard-common-admin-detect-autoconf.sh
new file mode 100644
index 000000000000..b87cf3d715b5
--- /dev/null
+++ b/devel/kdevelop/files/patch-parts-appwizard-common-admin-detect-autoconf.sh
@@ -0,0 +1,31 @@
+--- parts/appwizard/common/admin/detect-autoconf.sh.orig Wed Mar 3 22:22:59 2004
++++ parts/appwizard/common/admin/detect-autoconf.sh Wed Mar 3 21:47:49 2004
+@@ -17,6 +17,8 @@
+ AUTOCONF="`$WHICH autoconf-2.5x`"
+ elif test -x "`$WHICH autoconf-2.57 2>/dev/null`" ; then
+ AUTOCONF="`$WHICH autoconf-2.57`"
++ elif test -x "`$WHICH autoconf257 2>/dev/null`" ; then
++ AUTOCONF="`$WHICH autoconf257`"
+ elif test -x "`$WHICH autoconf-2.56 2>/dev/null`" ; then
+ AUTOCONF="`$WHICH autoconf-2.56`"
+ elif test -x "`$WHICH autoconf-2.55 2>/dev/null`" ; then
+@@ -42,6 +44,9 @@
+ elif test -x "`$WHICH autoheader-2.57 2>/dev/null`" ; then
+ AUTOHEADER="`$WHICH autoheader-2.57`"
+ AUTOM4TE="`$WHICH autom4te-2.57`"
++ elif test -x "`$WHICH autoheader257 2>/dev/null`" ; then
++ AUTOHEADER="`$WHICH autoheader257`"
++ AUTOM4TE="`$WHICH autom4te257`"
+ elif test -x "`$WHICH autoheader-2.56 2>/dev/null`" ; then
+ AUTOHEADER="`$WHICH autoheader-2.56`"
+ AUTOM4TE="`$WHICH autom4te-2.56`"
+@@ -72,6 +77,9 @@
+ elif test -x "`$WHICH automake-1.7 2>/dev/null`" ; then
+ AUTOMAKE="`$WHICH automake-1.7`"
+ ACLOCAL="`$WHICH aclocal-1.7`"
++ elif test -x "`$WHICH automake17 2>/dev/null`" ; then
++ AUTOMAKE="`$WHICH automake17`"
++ ACLOCAL="`$WHICH aclocal17`"
+ fi
+ if test -n "$UNSERMAKE"; then
+ AUTOMAKE="$UNSERMAKE"
diff --git a/devel/kdevelop/pkg-plist b/devel/kdevelop/pkg-plist
index db2fb87923b0..787892c00d31 100644
--- a/devel/kdevelop/pkg-plist
+++ b/devel/kdevelop/pkg-plist
@@ -15,6 +15,7 @@ include/kdevelop/catalog/tag.h
include/kdevelop/codemodel.h
include/kdevelop/codemodel_treeparser.h
include/kdevelop/codemodel_utils.h
+include/kdevelop/configwidgetproxy.h
include/kdevelop/cppparser/ast.h
include/kdevelop/cppparser/driver.h
include/kdevelop/cppparser/errors.h
@@ -162,6 +163,8 @@ lib/kde3/libkdevghcoptions.la
lib/kde3/libkdevghcoptions.so
lib/kde3/libkdevgrepview.la
lib/kde3/libkdevgrepview.so
+lib/kde3/libkdevhaskellproject.la
+lib/kde3/libkdevhaskellproject.so
lib/kde3/libkdevhaskellsupport.la
lib/kde3/libkdevhaskellsupport.so
lib/kde3/libkdevhistory.la
@@ -516,6 +519,7 @@ share/apps/kdevappwizard/template-kdedcop/mainclass.h
share/apps/kdevappwizard/template-kdedcop/script
share/apps/kdevappwizard/template-kdedcop/src-Makefile.am
share/apps/kdevappwizard/template-kdedcop/subdirs
+share/apps/kdevappwizard/template-kdevlang/README.dox
share/apps/kdevappwizard/template-kdevlang/app.kdevelop
share/apps/kdevappwizard/template-kdevlang/kdevlang-configure.in.in
share/apps/kdevappwizard/template-kdevlang/kdevlang.desktop
@@ -534,6 +538,7 @@ share/apps/kdevappwizard/template-kdevpart/kdevpart_widget.cpp
share/apps/kdevappwizard/template-kdevpart/kdevpart_widget.h
share/apps/kdevappwizard/template-kdevpart/script
share/apps/kdevappwizard/template-kdevpart/src-Makefile.am
+share/apps/kdevappwizard/template-kdevpart2/README.dox
share/apps/kdevappwizard/template-kdevpart2/app.kdevelop
share/apps/kdevappwizard/template-kdevpart2/kdevpart-configure.in.in
share/apps/kdevappwizard/template-kdevpart2/kdevpart.desktop
@@ -945,6 +950,7 @@ share/apps/kdevfortransupport/kdevfortransupport.rc
share/apps/kdevfullscreen/kdevpart_fullscreen.rc
share/apps/kdevgenericproject/kdevgenericproject.rc
share/apps/kdevgrepview/kdevgrepview.rc
+share/apps/kdevhaskellproject/kdevhaskellproject.rc
share/apps/kdevhaskellsupport/kdevhaskellsupport.rc
share/apps/kdevhistory/kdevhistory.rc
share/apps/kdevjavadebugger/kdevjavadebugger.rc
@@ -982,23 +988,37 @@ share/doc/HTML/en/kde_app_devel/common
share/doc/HTML/en/kde_app_devel/index.cache.bz2
share/doc/HTML/en/kde_app_devel/index.docbook
share/doc/HTML/en/kde_app_devel/kscribblefiles.png
+share/doc/HTML/en/kdevelop/SF-general.png
+share/doc/HTML/en/kdevelop/SF-indent.png
+share/doc/HTML/en/kdevelop/SF-other.png
share/doc/HTML/en/kdevelop/automake-file-popup.png
share/doc/HTML/en/kdevelop/automake-subproject-popup.png
share/doc/HTML/en/kdevelop/automake-target-popup.png
share/doc/HTML/en/kdevelop/automakemanager.png
share/doc/HTML/en/kdevelop/classview.png
share/doc/HTML/en/kdevelop/common
+share/doc/HTML/en/kdevelop/configure-editor.png
+share/doc/HTML/en/kdevelop/configure-file-selector.png
+share/doc/HTML/en/kdevelop/configure-general.png
+share/doc/HTML/en/kdevelop/configure-select.png
+share/doc/HTML/en/kdevelop/configure-snippets.png
share/doc/HTML/en/kdevelop/create-new-project-cvs.png
share/doc/HTML/en/kdevelop/createnewproject.png
share/doc/HTML/en/kdevelop/doctreeview.png
+share/doc/HTML/en/kdevelop/file-selector.png
share/doc/HTML/en/kdevelop/filetree.png
-share/doc/HTML/en/kdevelop/gideon-ideal-mode.png
-share/doc/HTML/en/kdevelop/gideon-mdi-mode.png
-share/doc/HTML/en/kdevelop/gideon-tabbed-mode.png
-share/doc/HTML/en/kdevelop/gideon-toplevel-mode.png
share/doc/HTML/en/kdevelop/importdirectory.png
share/doc/HTML/en/kdevelop/index.cache.bz2
share/doc/HTML/en/kdevelop/index.docbook
+share/doc/HTML/en/kdevelop/kdevelop-ideal-mode-0.png
+share/doc/HTML/en/kdevelop/kdevelop-ideal-mode.png
+share/doc/HTML/en/kdevelop/kdevelop-mdi-mode.png
+share/doc/HTML/en/kdevelop/kdevelop-tabbed-mode.png
+share/doc/HTML/en/kdevelop/kdevelop-toplevel-mode.png
+share/doc/HTML/en/kdevelop/loading-progress-bar.png
+share/doc/HTML/en/kdevelop/open-project.png
+share/doc/HTML/en/kdevelop/open-recent-project.png
+share/doc/HTML/en/kdevelop/select-user-interface-0.png
share/doc/HTML/en/kdevelop/select-user-interface.png
share/doc/HTML/en/kdevelop/wrong-project-location.png
share/icons/hicolor/16x16/actions/breakpoint_add.png
@@ -1103,6 +1123,7 @@ share/services/kdevgenericproject.desktop
share/services/kdevghcoptions.desktop
share/services/kdevgppoptions.desktop
share/services/kdevgrepview.desktop
+share/services/kdevhaskellproject.desktop
share/services/kdevhaskellsupport.desktop
share/services/kdevhistory.desktop
share/services/kdevjavadebugger.desktop
@@ -1159,35 +1180,15 @@ share/servicetypes/kdevelopplugin.desktop
share/servicetypes/kdevelopproject.desktop
share/servicetypes/kdevelopsourceformatter.desktop
share/servicetypes/kdevelopversioncontrol.desktop
-@dirrm share/servicetypes
-@dirrm share/services
-@dirrm share/mimelnk/text
-@dirrm share/mimelnk/application
-@dirrm share/mimelnk
@dirrm share/icons/locolor/32x32/actions
-@dirrm share/icons/locolor/32x32
@dirrm share/icons/locolor/16x16/actions
-@dirrm share/icons/locolor/16x16
-@dirrm share/icons/locolor
-@dirrm share/icons/hicolor/48x48/apps
@dirrm share/icons/hicolor/48x48/actions
-@dirrm share/icons/hicolor/48x48
-@dirrm share/icons/hicolor/32x32/mimetypes
-@dirrm share/icons/hicolor/32x32/apps
@dirrm share/icons/hicolor/32x32/actions
-@dirrm share/icons/hicolor/32x32
@dirrm share/icons/hicolor/22x22/actions
@dirrm share/icons/hicolor/22x22
-@dirrm share/icons/hicolor/16x16/apps
@dirrm share/icons/hicolor/16x16/actions
-@dirrm share/icons/hicolor/16x16
-@dirrm share/icons/hicolor
-@dirrm share/icons
@dirrm share/doc/HTML/en/kdevelop
@dirrm share/doc/HTML/en/kde_app_devel
-@dirrm share/doc/HTML/en
-@dirrm share/doc/HTML
-@dirrm share/config
@dirrm share/apps/qeditorpart/highlight
@dirrm share/apps/qeditorpart
@dirrm share/apps/manager
@@ -1215,6 +1216,7 @@ share/servicetypes/kdevelopversioncontrol.desktop
@dirrm share/apps/kdevjavadebugger
@dirrm share/apps/kdevhistory
@dirrm share/apps/kdevhaskellsupport
+@dirrm share/apps/kdevhaskellproject
@dirrm share/apps/kdevgrepview
@dirrm share/apps/kdevgenericproject
@dirrm share/apps/kdevfullscreen
@@ -1311,10 +1313,7 @@ share/servicetypes/kdevelopversioncontrol.desktop
@dirrm share/apps/kdevabbrev
@dirrm share/apps/devdoctreeview/indices
@dirrm share/apps/devdoctreeview
-@dirrm share/apps
@dirrm share/applnk/Development
-@dirrm share/applnk
-@dirrm lib/kde3
@dirrm include/kdevelop/cppparser
@dirrm include/kdevelop/catalog
@dirrm include/kdevelop