aboutsummaryrefslogtreecommitdiffstats
path: root/devel/kscope
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /devel/kscope
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'devel/kscope')
-rw-r--r--devel/kscope/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/devel/kscope/Makefile b/devel/kscope/Makefile
index 48ffa91bf79d..7f0a96ce07a7 100644
--- a/devel/kscope/Makefile
+++ b/devel/kscope/Makefile
@@ -27,7 +27,8 @@ USE_AUTOTOOLS= libtool
USE_GMAKE= yes
MAKE_ENV= EXTRA_LIBRARIES="-L${LOCALBASE}/lib"
-CONFIGURE_ENV= CXXFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
+LDFLAGS+= ${PTHREAD_LIBS}
+CXXFLAGS+= ${PTHREAD_CFLAGS}
CONFIGURE_ARGS+=--with-extra-includes=${LOCALBASE}/include \
--with-extra-libs=${LOCALBASE}/lib