aboutsummaryrefslogtreecommitdiffstats
path: root/devel/lbpp/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-06-03 22:00:20 +0800
committerijliao <ijliao@FreeBSD.org>2002-06-03 22:00:20 +0800
commitcf58c78ff2ee7a02578ec37ca39631765c3e57e7 (patch)
tree89af7fa1d9734506b897e5e4dcb89512b6ad5fd4 /devel/lbpp/Makefile
parenta365d38b1a6bdcd8864cc64228ea87e007286842 (diff)
downloadfreebsd-ports-gnome-cf58c78ff2ee7a02578ec37ca39631765c3e57e7.tar.gz
freebsd-ports-gnome-cf58c78ff2ee7a02578ec37ca39631765c3e57e7.tar.zst
freebsd-ports-gnome-cf58c78ff2ee7a02578ec37ca39631765c3e57e7.zip
add lbpp 0.0.6b
A front end to GCC from Liberty Basic source code
Diffstat (limited to 'devel/lbpp/Makefile')
-rw-r--r--devel/lbpp/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/lbpp/Makefile b/devel/lbpp/Makefile
new file mode 100644
index 000000000000..e37e27e102aa
--- /dev/null
+++ b/devel/lbpp/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: lbpp
+# Date created: Jun 4, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= lbpp
+PORTVERSION= 0.0.6b
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= yes
+
+post-patch:
+ @${GREP} -lR "malloc.h" ${WRKSRC} | ${XARGS} \
+ ${PERL} -pi -e "s/malloc.h/stdlib.h/g"
+ @${FIND} ${WRKSRC} -name "Makefile*" | ${XARGS} \
+ ${PERL} -pi -e "s,^CC,#CC,g ; s,^CFLAGS =,CFLAGS+=,g ; \
+ s,-Wall -g,,g"
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/lbpp ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/liblb/libLB.a ${PREFIX}/lib
+
+.include <bsd.port.mk>