aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libccid
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-03-10 01:15:43 +0800
committerstas <stas@FreeBSD.org>2009-03-10 01:15:43 +0800
commit08bfa7c4aa027efa35afd531304e476e4f713b80 (patch)
tree31b7120f0eb5ff46ed252641018a5ff19ff41fc3 /devel/libccid
parent982434000a36499258eff52f7032254355edca7a (diff)
downloadfreebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.tar.gz
freebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.tar.zst
freebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.zip
- Chase libusb20 rename in r189585.
- Mark sane-backends broken on current due to changes in USB stack. Reviewed by: thompsa (old version), miwi Tested by: miwi
Diffstat (limited to 'devel/libccid')
-rw-r--r--devel/libccid/Makefile7
-rw-r--r--devel/libccid/files/patch-src_ccid_usb.c11
-rw-r--r--devel/libccid/files/patch-src_parse.c10
3 files changed, 26 insertions, 2 deletions
diff --git a/devel/libccid/Makefile b/devel/libccid/Makefile
index 0f2b2455b28f..21b4ea0772a1 100644
--- a/devel/libccid/Makefile
+++ b/devel/libccid/Makefile
@@ -12,8 +12,7 @@ MASTER_SITES= http://alioth.debian.org/frs/download.php/2656/
MAINTAINER= arved@FreeBSD.org
COMMENT= Generic USB CCID (Chip/Smart Card Interface Devices) driver
-LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb \
- pcsclite.1:${PORTSDIR}/devel/pcsc-lite
+LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
USE_BZIP2= yes
GNU_CONFIGURE= yes
@@ -32,6 +31,10 @@ MAN8= Kobil_mIDentity_switch.8
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+.endif
+
post-patch:
${REINPLACE_CMD} -e "s,use warnings;,," ${WRKSRC}/src/create_Info_plist.pl
${REINPLACE_CMD} -e "s,ndef __APPLE__, !(__APPLE__ || __FreeBSD__)," ${WRKSRC}/contrib/Kobil_mIDentity_switch/Kobil_mIDentity_switch.c
diff --git a/devel/libccid/files/patch-src_ccid_usb.c b/devel/libccid/files/patch-src_ccid_usb.c
new file mode 100644
index 000000000000..58e515f48f8f
--- /dev/null
+++ b/devel/libccid/files/patch-src_ccid_usb.c
@@ -0,0 +1,11 @@
+--- src/ccid_usb.c.orig 2009-03-07 20:05:04.000000000 +0300
++++ src/ccid_usb.c 2009-03-07 20:09:14.000000000 +0300
+@@ -56,6 +56,8 @@
+
+ #define BUS_DEVICE_STRSIZE 32
+
++EXTERNAL struct usb_interface * get_ccid_usb_interface(struct usb_device *dev);
++
+ typedef struct
+ {
+ usb_dev_handle *handle;
diff --git a/devel/libccid/files/patch-src_parse.c b/devel/libccid/files/patch-src_parse.c
new file mode 100644
index 000000000000..76ec2e613f89
--- /dev/null
+++ b/devel/libccid/files/patch-src_parse.c
@@ -0,0 +1,10 @@
+--- src/parse.c.orig 2009-03-07 20:07:07.000000000 +0300
++++ src/parse.c 2009-03-07 20:09:07.000000000 +0300
+@@ -46,6 +46,7 @@
+
+ static int ccid_parse_interface_descriptor(usb_dev_handle *handle,
+ struct usb_device *dev);
++struct usb_interface * get_ccid_usb_interface(struct usb_device *dev);
+
+
+ /*****************************************************************************