aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libcfg
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-12 17:17:03 +0800
committerbapt <bapt@FreeBSD.org>2012-06-12 17:17:03 +0800
commitb67ba60a7d0b5167d89ba666bdb676db02c386e2 (patch)
tree04c579b603f0b42fdce1b378ded7e40d5fd46081 /devel/libcfg
parent3bcf5fedc5e27b6566c20a0863f490c35386e192 (diff)
downloadfreebsd-ports-gnome-b67ba60a7d0b5167d89ba666bdb676db02c386e2.tar.gz
freebsd-ports-gnome-b67ba60a7d0b5167d89ba666bdb676db02c386e2.tar.zst
freebsd-ports-gnome-b67ba60a7d0b5167d89ba666bdb676db02c386e2.zip
Convert to new options framework
Diffstat (limited to 'devel/libcfg')
-rw-r--r--devel/libcfg/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/devel/libcfg/Makefile b/devel/libcfg/Makefile
index df84df804838..51954d63e2a7 100644
--- a/devel/libcfg/Makefile
+++ b/devel/libcfg/Makefile
@@ -34,12 +34,11 @@ INSTALL_TARGET+= install-man
PORTDOCS= *
-OPTIONS= EXAMPLES "Install examples" off \
- HTMLDOCS "Install html documentation" off
+OPTIONS_DEFINE= EXAMPLES DOCS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_EXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
PLIST_SUB+= EXAMPLES=""
.else
PLIST_SUB+= EXAMPLES="@comment "
@@ -50,21 +49,19 @@ CFLAGS+= -fPIC
.endif
post-install:
-.if defined(WITH_EXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/doc/examples/example.* ${EXAMPLESDIR}
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for FILE in AUTHORS README TODO
@${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
.endfor
-.if defined(WITH_HTMLDOCS)
@${MKDIR} ${DOCSDIR}/html
@for FILE in ${WRKSRC}/doc/html/*; do \
${INSTALL_DATA} $${FILE} ${DOCSDIR}/html; \
done
.endif
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>