aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libclc
diff options
context:
space:
mode:
authorjmd <jmd@FreeBSD.org>2017-03-30 10:46:48 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2017-04-09 21:01:28 +0800
commitaaacdc33b31f76147ff2dca4bd12283809c63143 (patch)
tree12aa9342fecdefb55798fdbda1c0733790936790 /devel/libclc
parentcb4db96f61894e905918c4425789e95357de2d9a (diff)
downloadfreebsd-ports-gnome-aaacdc33b31f76147ff2dca4bd12283809c63143.tar.gz
freebsd-ports-gnome-aaacdc33b31f76147ff2dca4bd12283809c63143.tar.zst
freebsd-ports-gnome-aaacdc33b31f76147ff2dca4bd12283809c63143.zip
Update devel/libclc to a later git tag. It now requires devel/llvm40 and brings support for logb and expm1. License changes to BSD3 and MIT (dual).
Reviewed by: swills (mentor), rene (mentor), kwm (x11) Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D9394
Diffstat (limited to 'devel/libclc')
-rw-r--r--devel/libclc/Makefile15
-rw-r--r--devel/libclc/distinfo6
-rw-r--r--devel/libclc/pkg-descr1
-rw-r--r--devel/libclc/pkg-plist20
4 files changed, 32 insertions, 10 deletions
diff --git a/devel/libclc/Makefile b/devel/libclc/Makefile
index 708d694d44df..e8690791ca3e 100644
--- a/devel/libclc/Makefile
+++ b/devel/libclc/Makefile
@@ -2,26 +2,29 @@
# $FreeBSD$
PORTNAME= libclc
-DISTVERSION= 0.2.0.20160915
+DISTVERSION= 0.3.0.20170117
CATEGORIES= devel
MAINTAINER= x11@FreeBSD.org
COMMENT= Required library functions for OpenCL C programming language
-LICENSE= MIT
+LICENSE= BSD3CLAUSE MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
+LICENSE_COMB= dual
BUILD_DEPENDS= clang${LLVMVER}:devel/llvm${LLVMVER} \
libedit>=0:devel/libedit
USE_GITHUB= yes
GH_ACCOUNT= llvm-mirror
-GH_TAGNAME= b091e26
+GH_TAGNAME= 2ec7d80
-USES= gmake python:2,build ninja
+# ninja based build is broken since commit 598792bc (16 sep 2016)
+USES= gmake python:2.7,build gmake
USE_LDCONFIG= yes
MAKE_ENV= MAKE=${GMAKE} DESTDIR=${STAGEDIR}
-LLVMVER= 39
+LLVMVER= 40
ALL_TARGET=
@@ -32,7 +35,7 @@ post-patch:
${WRKSRC}/configure.py
do-configure:
- @cd ${WRKSRC} && ${PYTHON_CMD} configure.py ${CONFIGURE_ARGS} -g ninja \
+ @cd ${WRKSRC} && ${PYTHON_CMD} configure.py ${CONFIGURE_ARGS} -g make \
--with-llvm-config=${LOCALBASE}/bin/llvm-config${LLVMVER} \
--pkgconfigdir=${PREFIX}/libdata/pkgconfig \
--prefix=${PREFIX}
diff --git a/devel/libclc/distinfo b/devel/libclc/distinfo
index 71a0b8598d57..05728c2138bd 100644
--- a/devel/libclc/distinfo
+++ b/devel/libclc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1480100311
-SHA256 (llvm-mirror-libclc-0.2.0.20160915-b091e26_GH0.tar.gz) = 821a4b7aa0fa84b1a790b72ba9e2df2820f0d4f565df1027eaad206d688ea741
-SIZE (llvm-mirror-libclc-0.2.0.20160915-b091e26_GH0.tar.gz) = 127259
+TIMESTAMP = 1485361080
+SHA256 (llvm-mirror-libclc-0.3.0.20170117-2ec7d80_GH0.tar.gz) = 8e42ff411dbb8368d6719685864cc43312e02ff32bcc6785d1b25ee8d551837e
+SIZE (llvm-mirror-libclc-0.3.0.20170117-2ec7d80_GH0.tar.gz) = 130868
diff --git a/devel/libclc/pkg-descr b/devel/libclc/pkg-descr
index 496f7b97359a..87d33a2b43ad 100644
--- a/devel/libclc/pkg-descr
+++ b/devel/libclc/pkg-descr
@@ -6,4 +6,3 @@ impose library requirements:
Libclc is intended to be used with the Clang compiler's OpenCL frontend
WWW: http://libclc.llvm.org/
-
diff --git a/devel/libclc/pkg-plist b/devel/libclc/pkg-plist
index 88b3ee7fb8bc..ccf9f99a84a4 100644
--- a/devel/libclc/pkg-plist
+++ b/devel/libclc/pkg-plist
@@ -147,6 +147,7 @@ include/clc/math/exp.h
include/clc/math/exp10.h
include/clc/math/exp2.h
include/clc/math/exp2.inc
+include/clc/math/expm1.h
include/clc/math/fabs.h
include/clc/math/fdim.h
include/clc/math/fdim.inc
@@ -180,6 +181,8 @@ include/clc/math/log1p.h
include/clc/math/log1p.inc
include/clc/math/log2.h
include/clc/math/log2.inc
+include/clc/math/logb.h
+include/clc/math/logb.inc
include/clc/math/mad.h
include/clc/math/mad.inc
include/clc/math/modf.h
@@ -265,46 +268,63 @@ lib/clc/aruba-r600--.bc
lib/clc/barts-r600--.bc
lib/clc/bonaire-amdgcn--.bc
lib/clc/bonaire-amdgcn--amdhsa.bc
+lib/clc/bonaire-amdgcn-mesa-mesa3d.bc
lib/clc/caicos-r600--.bc
lib/clc/carrizo-amdgcn--.bc
lib/clc/carrizo-amdgcn--amdhsa.bc
+lib/clc/carrizo-amdgcn-mesa-mesa3d.bc
lib/clc/cayman-r600--.bc
lib/clc/cedar-r600--.bc
lib/clc/cypress-r600--.bc
lib/clc/fiji-amdgcn--.bc
lib/clc/fiji-amdgcn--amdhsa.bc
+lib/clc/fiji-amdgcn-mesa-mesa3d.bc
lib/clc/hainan-amdgcn--.bc
+lib/clc/hainan-amdgcn-mesa-mesa3d.bc
lib/clc/hawaii-amdgcn--.bc
lib/clc/hawaii-amdgcn--amdhsa.bc
+lib/clc/hawaii-amdgcn-mesa-mesa3d.bc
lib/clc/hemlock-r600--.bc
lib/clc/iceland-amdgcn--.bc
lib/clc/iceland-amdgcn--amdhsa.bc
+lib/clc/iceland-amdgcn-mesa-mesa3d.bc
lib/clc/juniper-r600--.bc
lib/clc/kabini-amdgcn--.bc
lib/clc/kabini-amdgcn--amdhsa.bc
+lib/clc/kabini-amdgcn-mesa-mesa3d.bc
lib/clc/kaveri-amdgcn--.bc
lib/clc/kaveri-amdgcn--amdhsa.bc
+lib/clc/kaveri-amdgcn-mesa-mesa3d.bc
lib/clc/mullins-amdgcn--.bc
lib/clc/mullins-amdgcn--amdhsa.bc
+lib/clc/mullins-amdgcn-mesa-mesa3d.bc
lib/clc/nvptx--nvidiacl.bc
lib/clc/nvptx64--nvidiacl.bc
lib/clc/oland-amdgcn--.bc
+lib/clc/oland-amdgcn-mesa-mesa3d.bc
lib/clc/palm-r600--.bc
lib/clc/pitcairn-amdgcn--.bc
+lib/clc/pitcairn-amdgcn-mesa-mesa3d.bc
lib/clc/polaris10-amdgcn--.bc
lib/clc/polaris10-amdgcn--amdhsa.bc
+lib/clc/polaris10-amdgcn-mesa-mesa3d.bc
lib/clc/polaris11-amdgcn--.bc
lib/clc/polaris11-amdgcn--amdhsa.bc
+lib/clc/polaris11-amdgcn-mesa-mesa3d.bc
lib/clc/redwood-r600--.bc
lib/clc/stoney-amdgcn--.bc
lib/clc/stoney-amdgcn--amdhsa.bc
+lib/clc/stoney-amdgcn-mesa-mesa3d.bc
lib/clc/subnormal_disable.bc
lib/clc/subnormal_use_default.bc
lib/clc/sumo-r600--.bc
lib/clc/sumo2-r600--.bc
lib/clc/tahiti-amdgcn--.bc
+lib/clc/tahiti-amdgcn-mesa-mesa3d.bc
lib/clc/tonga-amdgcn--.bc
lib/clc/tonga-amdgcn--amdhsa.bc
+lib/clc/tonga-amdgcn-mesa-mesa3d.bc
lib/clc/turks-r600--.bc
lib/clc/verde-amdgcn--.bc
+lib/clc/verde-amdgcn-mesa-mesa3d.bc
libdata/pkgconfig/libclc.pc