aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libclc
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-01-30 20:39:13 +0800
committermarino <marino@FreeBSD.org>2016-01-30 20:39:13 +0800
commit8332ff77f2dbcaa863d96cdcfb1413803e066506 (patch)
tree6169514483e9c662f7e6af30cddc892f477adf57 /devel/libclc
parent59edffd1a9e4d7e6cfd2d4c87822bdc236d91a25 (diff)
downloadfreebsd-ports-gnome-8332ff77f2dbcaa863d96cdcfb1413803e066506.tar.gz
freebsd-ports-gnome-8332ff77f2dbcaa863d96cdcfb1413803e066506.tar.zst
freebsd-ports-gnome-8332ff77f2dbcaa863d96cdcfb1413803e066506.zip
devel/libclc: Use ports libedit (build dependency)
The LLVM_TOOL_LINK builds a helper tool named utils/prepare-builtins that requires libedit which in turn pulls in libtinfo (part of libncurses). In order to support builds on platforms without base ncurses (e.g. DF), require base libedit. This requires an additional -L LDFLAGS to search ${LOCALBASE}/lib for the needed libs. (prepare-builtins is not installed) Approved by: kwm (maintainer)
Diffstat (limited to 'devel/libclc')
-rw-r--r--devel/libclc/Makefile3
-rw-r--r--devel/libclc/files/patch-configure.py22
2 files changed, 21 insertions, 4 deletions
diff --git a/devel/libclc/Makefile b/devel/libclc/Makefile
index 9d8b8370e7b8..493c259878eb 100644
--- a/devel/libclc/Makefile
+++ b/devel/libclc/Makefile
@@ -8,7 +8,8 @@ CATEGORIES= devel
MAINTAINER= kwm@FreeBSD.org
COMMENT= Required library functions for OpenCL C programming language
-BUILD_DEPENDS= clang${LLVMVER}:${PORTSDIR}/lang/clang${LLVMVER}
+BUILD_DEPENDS= clang${LLVMVER}:${PORTSDIR}/lang/clang${LLVMVER} \
+ libedit>=0:${PORTSDIR}/devel/libedit
USE_GITHUB= yes
GH_ACCOUNT= llvm-mirror
diff --git a/devel/libclc/files/patch-configure.py b/devel/libclc/files/patch-configure.py
index 7506dcc6753c..077d1c2a5cf9 100644
--- a/devel/libclc/files/patch-configure.py
+++ b/devel/libclc/files/patch-configure.py
@@ -1,6 +1,22 @@
---- configure.py.orig 2014-02-14 21:33:53.000000000 +0100
-+++ configure.py 2014-08-20 13:42:06.162076745 +0200
-@@ -228,7 +228,7 @@
+The LLVM_TOOL_LINK builds a helper tool named utils/prepare-builtins that
+requires libedit which in turn pulls in libtinfo (part of libncurses).
+In order to support builds on platforms without base ncurses (e.g. DF),
+require base libedit. This requires an additional -L LDFLAGS to search
+${LOCALBASE}/lib for the needed libs. (prepare-builtins is not installed)
+
+--- configure.py.orig 2015-07-10 13:37:04 UTC
++++ configure.py
+@@ -118,7 +118,8 @@ b.rule("OPT", command = llvm_opt + " -O3
+ description = 'OPT $out')
+
+ c_compiler_rule(b, "LLVM_TOOL_CXX", 'CXX', cxx_compiler, llvm_cxxflags)
+-b.rule("LLVM_TOOL_LINK", cxx_compiler + " -o $out $in %s" % llvm_core_libs + " -Wl,-rpath %s" % llvm_libdir, 'LINK $out')
++b.rule("LLVM_TOOL_LINK", cxx_compiler + " -o $out $in %s" % llvm_core_libs +
++ " -L" + prefix + "/lib -Wl,-rpath %s" % llvm_libdir, 'LINK $out')
+
+ prepare_builtins = os.path.join('utils', 'prepare-builtins')
+ b.build(os.path.join('utils', 'prepare-builtins.o'), "LLVM_TOOL_CXX",
+@@ -264,7 +265,7 @@ install_cmd = ' && '.join(['mkdir -p ${D
{'src': file,
'dst': libexecdir}
for (file, dest) in install_files_bc])