aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libdap
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-10-27 23:49:04 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-10-27 23:49:04 +0800
commit955bdb0dd183d71e910312d59f7bf024b7bbc695 (patch)
tree4c13eeaf930a132b521425661131b09b1eb0bb5d /devel/libdap
parent5c485605e701dc82b99c32dec940c8a537e84970 (diff)
downloadfreebsd-ports-gnome-955bdb0dd183d71e910312d59f7bf024b7bbc695.tar.gz
freebsd-ports-gnome-955bdb0dd183d71e910312d59f7bf024b7bbc695.tar.zst
freebsd-ports-gnome-955bdb0dd183d71e910312d59f7bf024b7bbc695.zip
- Fix build on -head
Reported by: pkg-fallout
Diffstat (limited to 'devel/libdap')
-rw-r--r--devel/libdap/Makefile8
-rw-r--r--devel/libdap/files/extra-patch-dds.yy13
2 files changed, 20 insertions, 1 deletions
diff --git a/devel/libdap/Makefile b/devel/libdap/Makefile
index ed1731f6d86b..9030847c899a 100644
--- a/devel/libdap/Makefile
+++ b/devel/libdap/Makefile
@@ -22,4 +22,10 @@ INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
USES= bison charsetfix gmake libtool localbase pathfix
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 1100000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-dds.yy
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/libdap/files/extra-patch-dds.yy b/devel/libdap/files/extra-patch-dds.yy
new file mode 100644
index 000000000000..2a38baaec66e
--- /dev/null
+++ b/devel/libdap/files/extra-patch-dds.yy
@@ -0,0 +1,13 @@
+--- dds.yy.orig 2014-11-20 20:00:18 UTC
++++ dds.yy
+@@ -261,8 +261,8 @@ declaration: base_type var ';'
+
+ | grid '{' SCAN_WORD ':'
+ {
+- if (is_keyword(string($3), "array"))
+- part = array;
++ if (is_keyword(string($3), "libdap::Part::array"))
++ part = libdap::Part::array;
+ else {
+ ostringstream msg;
+ msg << BAD_DECLARATION;