aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libdispatch
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-10-21 06:33:24 +0800
committerstas <stas@FreeBSD.org>2009-10-21 06:33:24 +0800
commit89d03bc78ea8cb0196e19a29e8052879e32bd6da (patch)
treef2c2b8116eb98473835aa50671c0487e02b8b912 /devel/libdispatch
parent82873dfae38cd8032ecc82526c79841a0b125011 (diff)
downloadfreebsd-ports-gnome-89d03bc78ea8cb0196e19a29e8052879e32bd6da.tar.gz
freebsd-ports-gnome-89d03bc78ea8cb0196e19a29e8052879e32bd6da.tar.zst
freebsd-ports-gnome-89d03bc78ea8cb0196e19a29e8052879e32bd6da.zip
- Update to r53.
- Add option for blocks support via clang.
Diffstat (limited to 'devel/libdispatch')
-rw-r--r--devel/libdispatch/Makefile16
-rw-r--r--devel/libdispatch/distinfo6
2 files changed, 17 insertions, 5 deletions
diff --git a/devel/libdispatch/Makefile b/devel/libdispatch/Makefile
index 1069303cce72..115ee96e8b64 100644
--- a/devel/libdispatch/Makefile
+++ b/devel/libdispatch/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= libdispatch
-PORTVERSION= 46
+PORTVERSION= 53
CATEGORIES= devel
MASTER_SITES= ftp://ftp.SpringDaemons.com/soft/
-DISTNAME= ${PORTNAME}-r${PORTVERSION}
+#DISTNAME= ${PORTNAME}-r${PORTVERSION}
MAINTAINER= stas@FreeBSD.org
COMMENT= Grand Central Dispatch API support library
@@ -18,6 +18,8 @@ GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_LDCONFIG= yes
+OPTIONS= CLANG "Build with LLVM/Clang (required for blocks support)" on
+
MAN3= dispatch.3 dispatch_after.3 dispatch_api.3 dispatch_apply.3 \
dispatch_async.3 dispatch_benchmark.3 dispatch_group_create.3 \
dispatch_object.3 dispatch_once.3 dispatch_queue_create.3 \
@@ -36,4 +38,14 @@ post-configure:
IGNORE= is not supported on this OS version
.endif
+.if !defined(WITHOUT_CLANG)
+BUILD_DEPENDS+= clang:${PORTSDIR}/devel/llvm-devel \
+ ${LOCALBASE}/lib/libBlocksRuntime.so:${PORTSDIR}/devel/compiler-rt
+RUN_DEPENDS+= clang:${PORTSDIR}/devel/llvm-devel \
+ ${LOCALBASE}/lib/libBlocksRuntime.so:${PORTSDIR}/devel/compiler-rt
+CONFIGURE_ARGS+= --with-blocks-runtime=/usr/local/lib
+CONFIGURE_ENV+= CC="clang"
+MAKE_ENV+= CC="clang"
+.endif
+
.include <bsd.port.post.mk>
diff --git a/devel/libdispatch/distinfo b/devel/libdispatch/distinfo
index fb87f11a9894..7c38920541b5 100644
--- a/devel/libdispatch/distinfo
+++ b/devel/libdispatch/distinfo
@@ -1,3 +1,3 @@
-MD5 (libdispatch-r46.tar.bz2) = 230c2be2d29b1a763421375cfdc71247
-SHA256 (libdispatch-r46.tar.bz2) = db0d038c1b4417a83fa575b3c9ab085ecd22e43533dbd84cd03b6517fe423689
-SIZE (libdispatch-r46.tar.bz2) = 294988
+MD5 (libdispatch-53.tar.bz2) = 58e72d70b07d1f9256cfc2d20f2c155a
+SHA256 (libdispatch-53.tar.bz2) = 1dd7b757e11b7aa15ce0ddf05c72338e878c8a53f7dba569da3c786aa22279e7
+SIZE (libdispatch-53.tar.bz2) = 294892