aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libdlmalloc/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1995-06-24 19:42:32 +0800
committerasami <asami@FreeBSD.org>1995-06-24 19:42:32 +0800
commitd21b71cc5a3e11bccc9aa5fe5763254cd565d9a5 (patch)
tree560e7eb8a07c987120c853aef90742f320b09b93 /devel/libdlmalloc/Makefile
parent8d54bac5baa3871cb4702456e31c93aedc116bd5 (diff)
downloadfreebsd-ports-gnome-d21b71cc5a3e11bccc9aa5fe5763254cd565d9a5.tar.gz
freebsd-ports-gnome-d21b71cc5a3e11bccc9aa5fe5763254cd565d9a5.tar.zst
freebsd-ports-gnome-d21b71cc5a3e11bccc9aa5fe5763254cd565d9a5.zip
Add
post-install: pkg_add -m ${PREFIX}/lib to Makefiles and @exec ldconfig -m %D to packing lists of ports that install shared libraries. This should get rid of a huge chunk of confusion for novice users! All hail Paul Kranenburg! :)
Diffstat (limited to 'devel/libdlmalloc/Makefile')
-rw-r--r--devel/libdlmalloc/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/devel/libdlmalloc/Makefile b/devel/libdlmalloc/Makefile
index f41a5466027f..77e5fe6430dc 100644
--- a/devel/libdlmalloc/Makefile
+++ b/devel/libdlmalloc/Makefile
@@ -3,7 +3,7 @@
# Date created: 3 June 1995
# Whom: roberto
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1995/06/04 05:29:57 asami Exp $
#
DISTNAME= dlmalloc
@@ -23,4 +23,7 @@ do-extract:
cp -p ${DISTDIR}/${DISTFILES} ${WRKDIR}
cp -p ${FILESDIR}/Makefile ${WRKDIR}
+post-install:
+ ldconfig -m ${PREFIX}/lib
+
.include <bsd.port.mk>