aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libdlmalloc
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-01-27 21:21:22 +0800
committerpav <pav@FreeBSD.org>2007-01-27 21:21:22 +0800
commitad826de0b89f571175e75a10f94e150075371ce2 (patch)
tree2ab6ef140ee78088966823ba14d9770008a616f7 /devel/libdlmalloc
parent8c54c80249291280c439df4921a8794b30cc177c (diff)
downloadfreebsd-ports-gnome-ad826de0b89f571175e75a10f94e150075371ce2.tar.gz
freebsd-ports-gnome-ad826de0b89f571175e75a10f94e150075371ce2.tar.zst
freebsd-ports-gnome-ad826de0b89f571175e75a10f94e150075371ce2.zip
- Remove a.out support
Diffstat (limited to 'devel/libdlmalloc')
-rw-r--r--devel/libdlmalloc/Makefile2
-rw-r--r--devel/libdlmalloc/files/Makefile8
-rw-r--r--devel/libdlmalloc/pkg-plist2
3 files changed, 2 insertions, 10 deletions
diff --git a/devel/libdlmalloc/Makefile b/devel/libdlmalloc/Makefile
index 097566d0cbb1..8e9cc779cf7c 100644
--- a/devel/libdlmalloc/Makefile
+++ b/devel/libdlmalloc/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= roberto@FreeBSD.org
COMMENT= Small, fast malloc library by Doug Lea
NO_WRKSUBDIR= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
do-extract:
@${MKDIR} ${WRKDIR}
diff --git a/devel/libdlmalloc/files/Makefile b/devel/libdlmalloc/files/Makefile
index 693c913e0212..73d4174832fb 100644
--- a/devel/libdlmalloc/files/Makefile
+++ b/devel/libdlmalloc/files/Makefile
@@ -20,11 +20,7 @@ LIBDIR=${PREFIX}/lib
INCDIR=${PREFIX}/include/dlmalloc
# for the shared lib stuff
-.if ${PORTOBJFORMAT} == "elf"
VERSION=${VER:R:R}
-.else
-VERSION=${VER:R}
-.endif
LIBMALLOC=libdlmalloc.a
LIBSMALLOC=libdlmalloc.so.${VERSION}
@@ -54,11 +50,7 @@ $(LIBMALLOC): $(OBJS)
$(LIBSMALLOC): $(SOBJS)
rm -f $(LIBSMALLOC)
-.if ${PORTOBJFORMAT} == "elf"
ld -Bshareable -soname $(LIBSMALLOC) -o $(LIBSMALLOC) $(SOBJS)
-.else
- ld -Bshareable -o $(LIBSMALLOC) $(SOBJS)
-.endif
clean:
-rm -f *.o \#* *~ *.core a.out gmon.out mon.out onefile.c *.sL prof.out
diff --git a/devel/libdlmalloc/pkg-plist b/devel/libdlmalloc/pkg-plist
index 19ec8980b7bd..469d5074abd3 100644
--- a/devel/libdlmalloc/pkg-plist
+++ b/devel/libdlmalloc/pkg-plist
@@ -1,5 +1,5 @@
include/dlmalloc/malloc.h
lib/libdlmalloc.a
lib/libdlmalloc.so
-lib/libdlmalloc.so.2.6
+lib/libdlmalloc.so.2
@dirrm include/dlmalloc