aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libdwarf
diff options
context:
space:
mode:
authorjoerg <joerg@FreeBSD.org>2007-11-07 20:43:49 +0800
committerjoerg <joerg@FreeBSD.org>2007-11-07 20:43:49 +0800
commite9773fa125349feeed3067191b082ea3f95ddfed (patch)
treec5d236972a3c4515094870d813c5453828eeadff /devel/libdwarf
parentef758600511eba734de257db734c118c780c64f9 (diff)
downloadfreebsd-ports-gnome-e9773fa125349feeed3067191b082ea3f95ddfed.tar.gz
freebsd-ports-gnome-e9773fa125349feeed3067191b082ea3f95ddfed.tar.zst
freebsd-ports-gnome-e9773fa125349feeed3067191b082ea3f95ddfed.zip
Fix brokeness where <malloc.h> was included even though <stdlib.h>
is already there. Approved by: portmgr (erwin)
Diffstat (limited to 'devel/libdwarf')
-rw-r--r--devel/libdwarf/Makefile1
-rw-r--r--devel/libdwarf/files/patch-pro_alloc.c16
2 files changed, 17 insertions, 0 deletions
diff --git a/devel/libdwarf/Makefile b/devel/libdwarf/Makefile
index 8eb0b01d9484..4bf51109277e 100644
--- a/devel/libdwarf/Makefile
+++ b/devel/libdwarf/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libdwarf
PORTVERSION= 20070703
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://reality.sgiweb.org/davea/
diff --git a/devel/libdwarf/files/patch-pro_alloc.c b/devel/libdwarf/files/patch-pro_alloc.c
new file mode 100644
index 000000000000..b34aa82b9a0b
--- /dev/null
+++ b/devel/libdwarf/files/patch-pro_alloc.c
@@ -0,0 +1,16 @@
+--- pro_alloc.c.orig Wed Jul 4 01:37:21 2007
++++ pro_alloc.c Wed Nov 7 12:35:05 2007
+@@ -40,11 +40,12 @@
+ #include "pro_incl.h"
+ #ifdef HAVE_STDLIB_H
+ #include <stdlib.h>
++#else
++#include <malloc.h>
+ #endif /* HAVE_STDLIB_H */
+ #ifdef HAVE_STRING_H
+ #include <string.h>
+ #endif /* HAVE_STRING_H */
+-#include <malloc.h>
+
+ /*
+ When each block is allocated, there is a two-word structure