aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libepoll-shim
diff options
context:
space:
mode:
authorrezny <rezny@FreeBSD.org>2017-07-10 08:54:21 +0800
committerrezny <rezny@FreeBSD.org>2017-07-10 08:54:21 +0800
commitc55faf45c73be4ae37aac6ccc38889022b50719b (patch)
tree750945790c70dc1402700602789319f89f417ef1 /devel/libepoll-shim
parent4e3841dd55f66af6c86072a53a5a2fc92474738d (diff)
downloadfreebsd-ports-gnome-c55faf45c73be4ae37aac6ccc38889022b50719b.tar.gz
freebsd-ports-gnome-c55faf45c73be4ae37aac6ccc38889022b50719b.tar.zst
freebsd-ports-gnome-c55faf45c73be4ae37aac6ccc38889022b50719b.zip
Build fixes for libepoll-shim
- correct compiler flags when using GCC; clears BROKEN on PPC64 - correct spelling of INCSDIR; fixes build when PREFIX != /usr/local [1] PR: 219576 [1] Submitted by: John Hein [1] Reported by: Mikhail T. [1] Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D11551
Diffstat (limited to 'devel/libepoll-shim')
-rw-r--r--devel/libepoll-shim/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/devel/libepoll-shim/Makefile b/devel/libepoll-shim/Makefile
index 4cda215546e3..13ed55eaaef0 100644
--- a/devel/libepoll-shim/Makefile
+++ b/devel/libepoll-shim/Makefile
@@ -10,8 +10,6 @@ COMMENT= epoll shim implemented using kevent
LICENSE= MIT
-BROKEN_powerpc64= fails to compile: cc1: error: unrecognized command line option -Wno-missing-variable-declarations
-
USE_GITHUB= yes
GH_ACCOUNT= FreeBSDDesktop
GH_PROJECT= epoll-shim
@@ -19,14 +17,18 @@ GH_TAGNAME= c04b26b
USE_LDCONFIG= yes
-USES= uidfix
-MAKE_ARGS= LIBDIR=${PREFIX}/lib INCLUDEDIR=${PREFIX}/include
+USES= compiler uidfix
+MAKE_ARGS= LIBDIR=${PREFIX}/lib INCSDIR=${PREFIX}/include/libepoll-shim/sys
+
+.include <bsd.port.pre.mk>
post-patch:
- # -Weverything is not recognized by GCC
- @${REINPLACE_CMD} -e 's|Weverything|Wall|' ${WRKSRC}/Makefile
+.if "${CHOSEN_COMPILER_TYPE}" == "gcc"
+ @${REINPLACE_CMD} -e 's|Wno-missing-variable-declarations|Wno-missing-declarations|' \
+ -e 's|-Wno-thread-safety-analysis||' -e 's|Weverything|Wall|' ${WRKSRC}/Makefile
+.endif
pre-install:
@${MKDIR} ${STAGEDIR}/${PREFIX}/include/libepoll-shim/sys
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>