aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libewf
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2018-06-13 00:40:32 +0800
committerantoine <antoine@FreeBSD.org>2018-06-13 00:40:32 +0800
commit40403ba1b6c5e94e5805d55633b091c78e326bee (patch)
treec8dd3340023f111f96623492e202d9e94a4feac5 /devel/libewf
parent65ed77db6ba50cb6e7a5148277b82c71dcad2d46 (diff)
downloadfreebsd-ports-gnome-40403ba1b6c5e94e5805d55633b091c78e326bee.tar.gz
freebsd-ports-gnome-40403ba1b6c5e94e5805d55633b091c78e326bee.tar.zst
freebsd-ports-gnome-40403ba1b6c5e94e5805d55633b091c78e326bee.zip
Do not use ssl (EVP), this fixes build with OpenSSL 1.1
PR: 228941
Diffstat (limited to 'devel/libewf')
-rw-r--r--devel/libewf/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/devel/libewf/Makefile b/devel/libewf/Makefile
index d4f5d76ffe21..769b0bf77190 100644
--- a/devel/libewf/Makefile
+++ b/devel/libewf/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libewf
PORTVERSION= 20140803
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= https://github.com/libyal/libewf-legacy/releases/download/${PORTVERSION}/ \
LOCAL/antoine
@@ -13,18 +14,16 @@ COMMENT= Library for support of the Expert Witness Compression Format (EWF)
LICENSE= LGPL3+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_SSL= openssl-devel
-BROKEN_SSL_REASON_openssl-devel= field has incomplete type 'EVP_MD_CTX' (aka 'struct evp_md_ctx_st')
-
LIB_DEPENDS= libsmdev.so:devel/libsmdev \
libsmraw.so:devel/libsmraw \
libuuid.so:misc/e2fsprogs-libuuid
-USES= fuse libtool pathfix pkgconfig python:2.7 ssl
+USES= fuse libtool pathfix pkgconfig python:2.7
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-python --with-libsmdev=${LOCALBASE} --with-libsmraw=${LOCALBASE} --with-libuuid=${LOCALBASE}
+CONFIGURE_ARGS= --enable-python --with-libsmdev=${LOCALBASE} --with-libsmraw=${LOCALBASE} \
+ --with-libuuid=${LOCALBASE} --with-openssl=no
INSTALL_TARGET= install-strip
OPTIONS_DEFINE= NLS