aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libffi
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-10-22 14:33:45 +0800
committerasami <asami@FreeBSD.org>1998-10-22 14:33:45 +0800
commit299ac73011ed074d5d56728667781b88d6e934a4 (patch)
treeb141a41f24796de7b7e997d42f2a13a7c9ea3caf /devel/libffi
parent9cc78c6a1fcda267ffcadb01c4e0e1c2dab06549 (diff)
downloadfreebsd-ports-gnome-299ac73011ed074d5d56728667781b88d6e934a4.tar.gz
freebsd-ports-gnome-299ac73011ed074d5d56728667781b88d6e934a4.tar.zst
freebsd-ports-gnome-299ac73011ed074d5d56728667781b88d6e934a4.zip
Looks like someone broke this while fixing the ELF case.... ;)
=== /bin/sh ../libtool --mode=link cc -O -pipe -o ffitest ffitest.o libffi.la libtool: link: warning: using a buggy system linker libtool: link: relinking will be required before `ffitest' can be installed cc -O -pipe -o .libs/ffitest ffitest.o /usr/ports/devel/libffi/work/libffi-1.18/src/.libs/libffi.so creating ffitest ./ffitest ld.so failed: Undefined symbol "ffi_prep_args" in ffitest:/usr/ports/devel/libffi/work/libffi-1.18/src/.libs/libffi.so *** Error code 1 Stop.
Diffstat (limited to 'devel/libffi')
-rw-r--r--devel/libffi/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/devel/libffi/Makefile b/devel/libffi/Makefile
index d6709ce9b5ac..c2cc2f48d34b 100644
--- a/devel/libffi/Makefile
+++ b/devel/libffi/Makefile
@@ -3,7 +3,7 @@
# Date created: 14, June, 1998
# Whom: Horance Chou <horance@freedom.ie.cycu.edu.tw>
#
-# $Id: Makefile,v 1.2 1998/10/12 18:42:20 jseger Exp $
+# $Id: Makefile,v 1.3 1998/10/20 01:35:24 steve Exp $
#
DISTNAME= libffi-1.18
@@ -12,6 +12,11 @@ MASTER_SITES= ftp://ftp.cygnus.com:/pub/green/
MAINTAINER= horance@freedom.ie.cycu.edu.tw
+VERSION!= sysctl -n kern.osreldate
+.if ${VERSION} < 300000
+BROKEN= undefined symbol in ffitest
+.endif
+
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PKGNAME}
ALL_TARGET= test