aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libgamepad
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-03-10 01:15:43 +0800
committerstas <stas@FreeBSD.org>2009-03-10 01:15:43 +0800
commit08bfa7c4aa027efa35afd531304e476e4f713b80 (patch)
tree31b7120f0eb5ff46ed252641018a5ff19ff41fc3 /devel/libgamepad
parent982434000a36499258eff52f7032254355edca7a (diff)
downloadfreebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.tar.gz
freebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.tar.zst
freebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.zip
- Chase libusb20 rename in r189585.
- Mark sane-backends broken on current due to changes in USB stack. Reviewed by: thompsa (old version), miwi Tested by: miwi
Diffstat (limited to 'devel/libgamepad')
-rw-r--r--devel/libgamepad/Makefile8
-rw-r--r--devel/libgamepad/files/extra-patch-gamepad_usbhid.c10
2 files changed, 17 insertions, 1 deletions
diff --git a/devel/libgamepad/Makefile b/devel/libgamepad/Makefile
index d935f197c4fc..9342adec1781 100644
--- a/devel/libgamepad/Makefile
+++ b/devel/libgamepad/Makefile
@@ -19,4 +19,10 @@ pre-build:
MAN3= libgamepad.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800069
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-gamepad_usbhid.c
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/libgamepad/files/extra-patch-gamepad_usbhid.c b/devel/libgamepad/files/extra-patch-gamepad_usbhid.c
new file mode 100644
index 000000000000..57de0a000c15
--- /dev/null
+++ b/devel/libgamepad/files/extra-patch-gamepad_usbhid.c
@@ -0,0 +1,10 @@
+--- gamepad_usbhid.c.orig 2009-03-08 12:35:35.000000000 +0300
++++ gamepad_usbhid.c 2009-03-08 12:35:44.000000000 +0300
+@@ -3,6 +3,7 @@
+ #include <string.h>
+ #include <sys/ioctl.h>
+ #include <dev/usb/usb.h>
++#include <dev/usb/usb_ioctl.h>
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <unistd.h>