aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libgtop/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-07-12 21:59:45 +0800
committersobomax <sobomax@FreeBSD.org>2002-07-12 21:59:45 +0800
commit064bd66cfedd40a5babe354014596675aacc8b52 (patch)
treebe77626daffb2faf454dd3d1fd0e0875e23122b9 /devel/libgtop/Makefile
parent5a5a06d2b6ebc3424e6c66031c9404d2b1ffb830 (diff)
downloadfreebsd-ports-gnome-064bd66cfedd40a5babe354014596675aacc8b52.tar.gz
freebsd-ports-gnome-064bd66cfedd40a5babe354014596675aacc8b52.tar.zst
freebsd-ports-gnome-064bd66cfedd40a5babe354014596675aacc8b52.zip
Use USE_REINPLACE.
Diffstat (limited to 'devel/libgtop/Makefile')
-rw-r--r--devel/libgtop/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/devel/libgtop/Makefile b/devel/libgtop/Makefile
index 4d2c32798b85..3c21eb2860fa 100644
--- a/devel/libgtop/Makefile
+++ b/devel/libgtop/Makefile
@@ -17,18 +17,17 @@ LIB_DEPENDS= guile.10:${PORTSDIR}/lang/guile
USE_PERL5= yes
USE_GMAKE= yes
-USE_GNOMELIBS= yes
+USE_REINPLACE= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomelibs
INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
post-install:
install-info --section="Programming \& development tools" \