aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libgtop2/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-05-30 11:45:40 +0800
committersteve <steve@FreeBSD.org>1999-05-30 11:45:40 +0800
commit2f0754de4af9c768c00be1fd9127ba678bbbf69e (patch)
tree0a6bb59b5dca0dfe96aeb2430a44e5173c50642c /devel/libgtop2/Makefile
parentbe1e508b9e238939292362ead7731bb05a4e8565 (diff)
downloadfreebsd-ports-gnome-2f0754de4af9c768c00be1fd9127ba678bbbf69e.tar.gz
freebsd-ports-gnome-2f0754de4af9c768c00be1fd9127ba678bbbf69e.tar.zst
freebsd-ports-gnome-2f0754de4af9c768c00be1fd9127ba678bbbf69e.zip
Use new gnome ports and set USE_LIBTOOL=yes.
PR: 11844 Submitted by: Jeremy Lea <reg@shale.csir.co.za>
Diffstat (limited to 'devel/libgtop2/Makefile')
-rw-r--r--devel/libgtop2/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/devel/libgtop2/Makefile b/devel/libgtop2/Makefile
index 320b0f875865..621ea559decb 100644
--- a/devel/libgtop2/Makefile
+++ b/devel/libgtop2/Makefile
@@ -3,7 +3,7 @@
# Date Created: 26 Sep 1998
# Whom: Vanilla I. Shu <vanilla@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.17 1999/03/09 01:08:53 nectar Exp $
+# $Id: Makefile,v 1.18 1999/04/08 18:08:32 steve Exp $
#
DISTNAME= libgtop-1.0.1
@@ -13,20 +13,16 @@ MASTER_SITE_SUBDIR= sources/libgtop
MAINTAINER= nacai@iname.com
-LIB_DEPENDS= gnome.1:${PORTSDIR}/x11/gnomelibs \
+LIB_DEPENDS= gnome.2:${PORTSDIR}/x11/gnomelibs \
guile.4:${PORTSDIR}/lang/guile
-# implicit dependencies:
-# gettext, glib12
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
USE_PERL5= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- GLIB_CONFIG="${LOCALBASE}/bin/glib12-config" \
- LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
-
-post-install:
- @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>