aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libgtop
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-07-12 21:59:45 +0800
committersobomax <sobomax@FreeBSD.org>2002-07-12 21:59:45 +0800
commit064bd66cfedd40a5babe354014596675aacc8b52 (patch)
treebe77626daffb2faf454dd3d1fd0e0875e23122b9 /devel/libgtop
parent5a5a06d2b6ebc3424e6c66031c9404d2b1ffb830 (diff)
downloadfreebsd-ports-gnome-064bd66cfedd40a5babe354014596675aacc8b52.tar.gz
freebsd-ports-gnome-064bd66cfedd40a5babe354014596675aacc8b52.tar.zst
freebsd-ports-gnome-064bd66cfedd40a5babe354014596675aacc8b52.zip
Use USE_REINPLACE.
Diffstat (limited to 'devel/libgtop')
-rw-r--r--devel/libgtop/Makefile13
-rw-r--r--devel/libgtop/files/patch-ac12
-rw-r--r--devel/libgtop/files/patch-ltmain.sh45
3 files changed, 16 insertions, 54 deletions
diff --git a/devel/libgtop/Makefile b/devel/libgtop/Makefile
index 4d2c32798b85..3c21eb2860fa 100644
--- a/devel/libgtop/Makefile
+++ b/devel/libgtop/Makefile
@@ -17,18 +17,17 @@ LIB_DEPENDS= guile.10:${PORTSDIR}/lang/guile
USE_PERL5= yes
USE_GMAKE= yes
-USE_GNOMELIBS= yes
+USE_REINPLACE= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomelibs
INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
post-install:
install-info --section="Programming \& development tools" \
diff --git a/devel/libgtop/files/patch-ac b/devel/libgtop/files/patch-ac
index 586694a034dd..6a12baf28924 100644
--- a/devel/libgtop/files/patch-ac
+++ b/devel/libgtop/files/patch-ac
@@ -1,8 +1,8 @@
$FreeBSD$
---- configure.orig Mon Jan 28 16:26:32 2002
-+++ configure Mon Jan 28 16:34:25 2002
+--- configure.orig Tue Nov 27 00:50:58 2001
++++ configure Fri Jul 12 15:38:19 2002
@@ -1260,10 +1260,10 @@
# The aliases save the names the user supplied, while $host etc.
@@ -31,3 +31,11 @@ $FreeBSD$
LT_VERSION_INFO='-version-info ${LT_CURRENT}:${LT_REVISION}:${LT_AGE}'
if test x = y; then
+@@ -7555,6 +7555,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/devel/libgtop/files/patch-ltmain.sh b/devel/libgtop/files/patch-ltmain.sh
deleted file mode 100644
index 91713d2306f8..000000000000
--- a/devel/libgtop/files/patch-ltmain.sh
+++ /dev/null
@@ -1,45 +0,0 @@
-
-$FreeBSD$
-
---- ltmain.sh.orig Wed Jan 23 11:38:40 2002
-+++ ltmain.sh Sun Feb 3 01:44:17 2002
-@@ -1037,8 +1037,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -2412,6 +2420,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4179,10 +4190,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"