aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libhid
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-03-10 01:15:43 +0800
committerstas <stas@FreeBSD.org>2009-03-10 01:15:43 +0800
commit08bfa7c4aa027efa35afd531304e476e4f713b80 (patch)
tree31b7120f0eb5ff46ed252641018a5ff19ff41fc3 /devel/libhid
parent982434000a36499258eff52f7032254355edca7a (diff)
downloadfreebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.tar.gz
freebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.tar.zst
freebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.zip
- Chase libusb20 rename in r189585.
- Mark sane-backends broken on current due to changes in USB stack. Reviewed by: thompsa (old version), miwi Tested by: miwi
Diffstat (limited to 'devel/libhid')
-rw-r--r--devel/libhid/Makefile11
-rw-r--r--devel/libhid/files/extra-patch-usb12
-rw-r--r--devel/libhid/files/patch-src_hid_initialisation.c10
-rw-r--r--devel/libhid/files/patch-src_hid_opening.c9
-rw-r--r--devel/libhid/files/patch-src_hid_parsing.c9
-rw-r--r--devel/libhid/files/patch-test_lshid.c10
-rw-r--r--devel/libhid/files/patch-test_test_libhid.c9
7 files changed, 68 insertions, 2 deletions
diff --git a/devel/libhid/Makefile b/devel/libhid/Makefile
index 43568e1d1d7f..e9b915dca0ef 100644
--- a/devel/libhid/Makefile
+++ b/devel/libhid/Makefile
@@ -20,7 +20,6 @@ USE_LDCONFIG= yes
USE_GMAKE= yes
USE_PYTHON= yes
-LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
BUILD_DEPENDS+= ${LOCALBASE}/bin/xsltproc:${PORTSDIR}/textproc/libxslt \
${LOCALBASE}/share/xsl/docbook/html:${PORTSDIR}/textproc/docbook-xsl \
${LOCALBASE}/bin/swig1.3:${PORTSDIR}/devel/swig13
@@ -28,4 +27,12 @@ BUILD_DEPENDS+= ${LOCALBASE}/bin/xsltproc:${PORTSDIR}/textproc/libxslt \
HAS_CONFIGURE= yes
CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man --without-doxygen
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+.else
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-usb
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/libhid/files/extra-patch-usb b/devel/libhid/files/extra-patch-usb
new file mode 100644
index 000000000000..af78de7e0e45
--- /dev/null
+++ b/devel/libhid/files/extra-patch-usb
@@ -0,0 +1,12 @@
+--- configure.orig 2007-04-26 04:25:25.000000000 +0400
++++ configure 2009-03-07 20:26:02.000000000 +0300
+@@ -4846,8 +4846,8 @@
+ done
+
+
+- LIBUSB_CFLAGS="`libusb-config --cflags`"
+- LIBUSB_LIBS="`libusb-config --libs`"
++ LIBUSB_CFLAGS=""
++ LIBUSB_LIBS="-lusb"
+
+
diff --git a/devel/libhid/files/patch-src_hid_initialisation.c b/devel/libhid/files/patch-src_hid_initialisation.c
new file mode 100644
index 000000000000..014adf4987dd
--- /dev/null
+++ b/devel/libhid/files/patch-src_hid_initialisation.c
@@ -0,0 +1,10 @@
+--- src/hid_initialisation.c.orig 2009-03-07 20:27:43.000000000 +0300
++++ src/hid_initialisation.c 2009-03-07 20:29:25.000000000 +0300
+@@ -4,6 +4,7 @@
+ #define HID_INTERNAL
+
+ #include "config.h"
++#include <stdlib.h>
+ #include <hid.h>
+ #include <hid_helpers.h>
+
diff --git a/devel/libhid/files/patch-src_hid_opening.c b/devel/libhid/files/patch-src_hid_opening.c
new file mode 100644
index 000000000000..19b080d901ee
--- /dev/null
+++ b/devel/libhid/files/patch-src_hid_opening.c
@@ -0,0 +1,9 @@
+--- src/hid_opening.c.orig 2009-03-07 20:28:09.000000000 +0300
++++ src/hid_opening.c 2009-03-07 20:29:17.000000000 +0300
+@@ -1,5 +1,6 @@
+ #define HID_INTERNAL
+
++#include <stdlib.h>
+ #include <hid.h>
+ #include <hid_helpers.h>
+ #include <os.h>
diff --git a/devel/libhid/files/patch-src_hid_parsing.c b/devel/libhid/files/patch-src_hid_parsing.c
new file mode 100644
index 000000000000..3eccd4b712e1
--- /dev/null
+++ b/devel/libhid/files/patch-src_hid_parsing.c
@@ -0,0 +1,9 @@
+--- src/hid_parsing.c.orig 2009-03-07 20:29:35.000000000 +0300
++++ src/hid_parsing.c 2009-03-07 20:29:43.000000000 +0300
+@@ -1,5 +1,6 @@
+ #define HID_INTERNAL
+
++#include <stdlib.h>
+ #include <hid.h>
+ #include <hid_helpers.h>
+
diff --git a/devel/libhid/files/patch-test_lshid.c b/devel/libhid/files/patch-test_lshid.c
new file mode 100644
index 000000000000..2b107ca7b9a1
--- /dev/null
+++ b/devel/libhid/files/patch-test_lshid.c
@@ -0,0 +1,10 @@
+--- test/lshid.c.orig 2009-03-07 20:30:14.000000000 +0300
++++ test/lshid.c 2009-03-07 20:30:20.000000000 +0300
+@@ -23,6 +23,7 @@
+
+ #include <hid.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+
+ char *hid_id[32]; /* FIXME: 32 devices MAX */
diff --git a/devel/libhid/files/patch-test_test_libhid.c b/devel/libhid/files/patch-test_test_libhid.c
new file mode 100644
index 000000000000..dbb18830a719
--- /dev/null
+++ b/devel/libhid/files/patch-test_test_libhid.c
@@ -0,0 +1,9 @@
+--- test/test_libhid.c.orig 2009-03-07 20:29:59.000000000 +0300
++++ test/test_libhid.c 2009-03-07 20:30:05.000000000 +0300
+@@ -1,5 +1,6 @@
+ #include <hid.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+
+ bool match_serial_number(struct usb_dev_handle* usbdev, void* custom, unsigned int len)