aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libhtp
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2012-10-10 19:41:35 +0800
committerzi <zi@FreeBSD.org>2012-10-10 19:41:35 +0800
commit84aa4649b6f2abb4b322f4162c7fff9aafd0c5ce (patch)
tree37ecdd21b45233e5c1fef39aeb2f8dad0d323b03 /devel/libhtp
parent0a29b310fde74c7c81174108b02c27d7d49c1edb (diff)
downloadfreebsd-ports-gnome-84aa4649b6f2abb4b322f4162c7fff9aafd0c5ce.tar.gz
freebsd-ports-gnome-84aa4649b6f2abb4b322f4162c7fff9aafd0c5ce.tar.zst
freebsd-ports-gnome-84aa4649b6f2abb4b322f4162c7fff9aafd0c5ce.zip
- Add patch to fix null dereference
- Bump PORTREVISION Approved by: wxs@ (maintainer) Obtained from: Upstream bug repo
Diffstat (limited to 'devel/libhtp')
-rw-r--r--devel/libhtp/Makefile2
-rw-r--r--devel/libhtp/files/patch-htp__htp_util.c22
2 files changed, 23 insertions, 1 deletions
diff --git a/devel/libhtp/Makefile b/devel/libhtp/Makefile
index 52147c25c942..eed891b61712 100644
--- a/devel/libhtp/Makefile
+++ b/devel/libhtp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libhtp
PORTVERSION= 0.3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
#MASTER_SITES= # This port uses github
diff --git a/devel/libhtp/files/patch-htp__htp_util.c b/devel/libhtp/files/patch-htp__htp_util.c
new file mode 100644
index 000000000000..ceb152e0a157
--- /dev/null
+++ b/devel/libhtp/files/patch-htp__htp_util.c
@@ -0,0 +1,22 @@
+--- ./htp/htp_util.c.orig 2012-10-09 18:53:48.000000000 -0400
++++ ./htp/htp_util.c 2012-10-09 18:54:31.000000000 -0400
+@@ -2099,7 +2099,8 @@
+ len += bstr_len(hl->line);
+ }
+
+- len += bstr_len(tx->request_headers_sep);
++ if (tx->request_headers_sep)
++ len += bstr_len(tx->request_headers_sep);
+
+ request_headers_raw = bstr_alloc(len);
+ if (request_headers_raw == NULL) {
+@@ -2112,7 +2113,8 @@
+ bstr_add_noex(request_headers_raw, hl->line);
+ }
+
+- bstr_add_noex(request_headers_raw, tx->request_headers_sep);
++ if (tx->request_headers_sep)
++ bstr_add_noex(request_headers_raw, tx->request_headers_sep);
+
+ return request_headers_raw;
+ }