aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libixp
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-02-18 04:52:47 +0800
committersat <sat@FreeBSD.org>2007-02-18 04:52:47 +0800
commit8b081eee9f2ad4c480a8588ff06f48d222a60f76 (patch)
treef44acb291808e2f8db3f99712a0df02c2e41f0d9 /devel/libixp
parent0d2c22e66bcc17c85db5e30382d16320e496c788 (diff)
downloadfreebsd-ports-gnome-8b081eee9f2ad4c480a8588ff06f48d222a60f76.tar.gz
freebsd-ports-gnome-8b081eee9f2ad4c480a8588ff06f48d222a60f76.tar.zst
freebsd-ports-gnome-8b081eee9f2ad4c480a8588ff06f48d222a60f76.zip
Add port devel/libixp:
libixp is a stand-alone client/server 9P library including ixpc client which behaves like wmiir in the past. It consists of less than 2000 lines of code (including ixpc). libixp's server api is based heavily on that of Plan 9's lib9p, and the two libraries export virtually identical data structures. WWW: http://www.suckless.org/wiki/libs Inspired by: Gentoo ebuild, OpenBSD port
Diffstat (limited to 'devel/libixp')
-rw-r--r--devel/libixp/Makefile32
-rw-r--r--devel/libixp/distinfo3
-rw-r--r--devel/libixp/pkg-descr8
3 files changed, 43 insertions, 0 deletions
diff --git a/devel/libixp/Makefile b/devel/libixp/Makefile
new file mode 100644
index 000000000000..075cd8b31a3e
--- /dev/null
+++ b/devel/libixp/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: libixp
+# Date created: 17 February 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libixp
+PORTVERSION= 0.2
+CATEGORIES= devel
+MASTER_SITES= http://www.suckless.org/download/ GENTOO/distfiles
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Standalone client/server 9P library
+
+USE_LDCONFIG= yes
+CFLAGS+= -I. -fPIC
+LDFLAGS+= -L.
+MAKE_ARGS= PREFIX="${PREFIX}" CC="${CC}" MANPREFIX="${MANPREFIX}/man" \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+MAN1= ixpc.1
+PLIST_FILES= bin/ixpc include/ixp.h lib/libixp.so lib/libixp.so.0
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|\.a|.so|g;/RANLIB/d;s|{AR}|{CC} -shared -fPIC -o|;s|AR|CC|'\
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|"VERSION"|${PORTVERSION}|' ${WRKSRC}/ixpc.c
+
+post-install:
+ @${LN} -sf ${PREFIX}/lib/libixp.so ${PREFIX}/lib/libixp.so.0
+
+.include <bsd.port.mk>
diff --git a/devel/libixp/distinfo b/devel/libixp/distinfo
new file mode 100644
index 000000000000..c20eb1e10e38
--- /dev/null
+++ b/devel/libixp/distinfo
@@ -0,0 +1,3 @@
+MD5 (libixp-0.2.tar.gz) = e50c613f7410bc1cff3a18926804202f
+SHA256 (libixp-0.2.tar.gz) = 5e5eec16dd02bce3f014b90df029e91136031852568ff9a147d3f99f6eaf0143
+SIZE (libixp-0.2.tar.gz) = 20701
diff --git a/devel/libixp/pkg-descr b/devel/libixp/pkg-descr
new file mode 100644
index 000000000000..e10f9b62e437
--- /dev/null
+++ b/devel/libixp/pkg-descr
@@ -0,0 +1,8 @@
+libixp is a stand-alone client/server 9P library including ixpc client
+which behaves like wmiir in the past. It consists of less than 2000
+lines of code (including ixpc).
+
+libixp's server api is based heavily on that of Plan 9's lib9p, and the
+two libraries export virtually identical data structures.
+
+WWW: http://www.suckless.org/wiki/libs