aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libmcs/Makefile
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2007-10-16 03:49:44 +0800
committeroliver <oliver@FreeBSD.org>2007-10-16 03:49:44 +0800
commitafcf845099b4bedaa5c3453b0a9d25885e541523 (patch)
tree73c54bd5bf7d5277ef9a9d61b3667c5f13dc93fc /devel/libmcs/Makefile
parentc7384edafb937a024389958a683221ab10708848 (diff)
downloadfreebsd-ports-gnome-afcf845099b4bedaa5c3453b0a9d25885e541523.tar.gz
freebsd-ports-gnome-afcf845099b4bedaa5c3453b0a9d25885e541523.tar.zst
freebsd-ports-gnome-afcf845099b4bedaa5c3453b0a9d25885e541523.zip
make gconf support optional
Diffstat (limited to 'devel/libmcs/Makefile')
-rw-r--r--devel/libmcs/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/devel/libmcs/Makefile b/devel/libmcs/Makefile
index c8f3c8814ba1..3f63f51efad6 100644
--- a/devel/libmcs/Makefile
+++ b/devel/libmcs/Makefile
@@ -16,12 +16,26 @@ COMMENT= A BSD licenced configuration database system
LIB_DEPENDS= mowgli.1:${PORTSDIR}/devel/libmowgli
+OPTIONS= GCONF "Enable gconf support" on
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GMAKE= yes
+USE_GNOME= pkgconfig
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_GCONF)
+USE_GNOME+= gconf2
+CONFIGURE_ARGS+=--enable-gconf
+PLIST_SUB= GCONF=""
+.else
+CONFIGURE_ARGS+=--disable-gconf
+PLIST_SUB= GCONF="@comment "
+.endif
post-patch:
@${REINPLACE_CMD} 's|$${libdir}/pkgconfig|$${prefix}/libdata/pkgconfig|g' \
${WRKSRC}/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>