aboutsummaryrefslogtreecommitdiffstats
path: root/devel/liboop/Makefile
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2003-01-26 07:18:09 +0800
committerarved <arved@FreeBSD.org>2003-01-26 07:18:09 +0800
commit465ab5c50bcc4b11dd2c38e2ecd4a461b16385be (patch)
tree658789bbca61e12224bd0fafb23ac072b95d2229 /devel/liboop/Makefile
parent52ace2d623f4b4989ea39e8b67432474679f99cc (diff)
downloadfreebsd-ports-gnome-465ab5c50bcc4b11dd2c38e2ecd4a461b16385be.tar.gz
freebsd-ports-gnome-465ab5c50bcc4b11dd2c38e2ecd4a461b16385be.tar.zst
freebsd-ports-gnome-465ab5c50bcc4b11dd2c38e2ecd4a461b16385be.zip
Update to 0.9
PR: 47475 Submitted by: arved
Diffstat (limited to 'devel/liboop/Makefile')
-rw-r--r--devel/liboop/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/devel/liboop/Makefile b/devel/liboop/Makefile
index 2591c1b2b1cc..6fcf4c78069e 100644
--- a/devel/liboop/Makefile
+++ b/devel/liboop/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= liboop
-PORTVERSION= 0.8
-PORTREVISION= 1
+PORTVERSION= 0.9
CATEGORIES= devel
MASTER_SITES= http://download.ofb.net/liboop/
@@ -17,18 +16,16 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= adns.1:${PORTSDIR}/net/adns \
wwwcore.1:${PORTSDIR}/www/libwww
+USE_BZIP2= yes
USE_GNOMENG= yes
USE_GNOME= glib12
USE_LIBTOOL= yes
-USE_REINPLACE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
+ PROG_GLIB_CONFIG="${GLIB_CONFIG}"
INSTALLS_SHLIB= yes
-CPPFLAGS= -I${LOCALBASE}/include/w3c-libwww -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
-
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|glib-config|${GLIB_CONFIG:T}|g' ${WRKSRC}/configure
+CPPFLAGS= `libwww-config --cflags` -I${LOCALBASE}/include
+LDFLAGS= `libwww-config --libs` -L${LOCALBASE}/lib
.include <bsd.port.mk>