aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libopkele
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-07-17 16:14:42 +0800
committerpav <pav@FreeBSD.org>2008-07-17 16:14:42 +0800
commit580a7e2f6c1c7568a378042e6df38be73303ac7f (patch)
treeaa3861a70e23f59b78dae7e1f38c4959ca85c9a3 /devel/libopkele
parent201f8f3a27827858af9a61c1f20a2a376f4274cb (diff)
downloadfreebsd-ports-gnome-580a7e2f6c1c7568a378042e6df38be73303ac7f.tar.gz
freebsd-ports-gnome-580a7e2f6c1c7568a378042e6df38be73303ac7f.tar.zst
freebsd-ports-gnome-580a7e2f6c1c7568a378042e6df38be73303ac7f.zip
- Do dirty trick to use OpenSSL from ports on 6.x
Diffstat (limited to 'devel/libopkele')
-rw-r--r--devel/libopkele/Makefile20
1 files changed, 7 insertions, 13 deletions
diff --git a/devel/libopkele/Makefile b/devel/libopkele/Makefile
index 1d7472f230f5..4e73bbde3b29 100644
--- a/devel/libopkele/Makefile
+++ b/devel/libopkele/Makefile
@@ -32,20 +32,14 @@ CONFIGURE_ENV= "OPENSSL_CFLAGS=${CFLAGS} -l${OPENSSLINC}" \
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS= "-L${LOCALBASE}/lib"
-# Required version of OpenSSL for this build
-OPENSSL_SHLIBVER=5
+# This port needs OpenSSL 0.9.8b which is present in 7.0 and up
+.if !exists(/usr/include/openssl/store.h)
+WITH_OPENSSL_PORT= yes
+.endif
+
# If we use the base OpenSSL either by default or
# by design, we need to remove the openssl dependency
-# in pkgconfig/libopkele.pc. For the moment, the only
-# way I kan think of is to check for 7.0 with OpenSSL 0.9.8b
-# and not WITH_OPENSSL_PORT. As 6 requires the port, add this
-# as a dependency instead.
-
-.include <bsd.port.pre.mk>
-
-.if ( ${OSVERSION} < 700019 )
- WITH_OPENSSL_PORT=yes
-.endif
+# in pkgconfig/libopkele.pc.
post-patch:
@ ${REINPLACE_CMD} -e "s|pkgconfigdir =.*|pkgconfigdir = ${PREFIX}/libdata/pkgconfig|g" \
@@ -54,4 +48,4 @@ post-patch:
@ ${REINPLACE_CMD} -e "s|Requires: openssl|Requires:|" ${WRKSRC}/libopkele.pc.in
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>