aboutsummaryrefslogtreecommitdiffstats
path: root/devel/librcc
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-05-23 10:27:22 +0800
committerjgh <jgh@FreeBSD.org>2013-05-23 10:27:22 +0800
commitc320816067bbebb0b0f197bcee87ac7785eb832c (patch)
tree6944177e8ac080f07e5d737a57d86ca726dbcee4 /devel/librcc
parent594dc7cfdcd72c68fe2f15d879e78ef30d7cc814 (diff)
downloadfreebsd-ports-gnome-c320816067bbebb0b0f197bcee87ac7785eb832c.tar.gz
freebsd-ports-gnome-c320816067bbebb0b0f197bcee87ac7785eb832c.tar.zst
freebsd-ports-gnome-c320816067bbebb0b0f197bcee87ac7785eb832c.zip
- adoption of optionsNG
- trim historical headers Approved by: portmgr (miwi)
Diffstat (limited to 'devel/librcc')
-rw-r--r--devel/librcc/Makefile29
1 files changed, 13 insertions, 16 deletions
diff --git a/devel/librcc/Makefile b/devel/librcc/Makefile
index 32f9966d05bf..d510d4fae003 100644
--- a/devel/librcc/Makefile
+++ b/devel/librcc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: librcc
-# Date created: 30-12-2007
-# Whom: Ulrich Spoerlein <uspoerlein@gmail.com>
-#
+# Created by: Ulrich Spoerlein <uspoerlein@gmail.com>
# $FreeBSD$
-#
PORTNAME= librcc
PORTVERSION= 0.2.9
@@ -35,15 +31,16 @@ LIBS= -L${LOCALBASE}/lib
CONFIGURE_ENV= LIBS="${LIBS}"
-OPTIONS= BDB "Translation database support" off \
- TRANSLATE "Online translation support" off \
- TOOLS "Install recode configuration utility" on \
- GTK1 "Use Gtk1 library/frontend" on \
- GTK2 "Use Gtk2 library/frontend" on
+OPTIONS_DEFINE= BDB TRANSLATE TOOLS GTK1 GTK2
+BDB_DESC= Translation database support
+TRANSLATE_DESC= Online translation support
+TOOLS_DESC= Recode configuration utility
+
+OPTIONS_DEFAULT= TOOLS GTK1 GTK2
.include <bsd.port.options.mk>
-.if defined(WITH_BDB)
+.if ${PORT_OPTIONS:MBDB}
USE_BDB= 41+
CPPFLAGS+= -I${BDB_INCLUDE_DIR}
LIBS+= -L${BDB_LIB_DIR}
@@ -52,14 +49,14 @@ CONFIGURE_ARGS+=--enable-bdb
CONFIGURE_ARGS+=--disable-bdb
.endif
-.if defined(WITH_TRANSLATE)
+.if ${PORT_OPTIONS:MTRANSLATE}
LIB_DEPENDS+= translate.0:${PORTSDIR}/textproc/libtranslate
CONFIGURE_ARGS+=--enable-libtranslate
.else
CONFIGURE_ARGS+=--disable-libtranslate
.endif
-.if defined(WITH_GTK1)
+.if ${PORT_OPTIONS:MGTK1}
USE_GNOME+= glib12 gtk12
PLIST_SUB+= WITH_GTK1=""
.else
@@ -67,7 +64,7 @@ CONFIGURE_ENV+= ac_cv_path_GTK_CONFIG=no GTK_CONFIG=no
PLIST_SUB+= WITH_GTK1="@comment "
.endif
-.if defined(WITH_GTK2)
+.if ${PORT_OPTIONS:MGTK2}
USE_GNOME+= gtk20
PLIST_SUB+= WITH_GTK2=""
.else
@@ -75,7 +72,7 @@ CONFIGURE_ARGS+=--disable-glib2 --disable-gtk2
PLIST_SUB+= WITH_GTK2="@comment "
.endif
-.if defined(WITH_TOOLS)
+.if ${PORT_OPTIONS:MTOOLS}
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-rcc-config
PLIST_SUB+= TOOLS=""
.else
@@ -84,7 +81,7 @@ PLIST_SUB+= TOOLS="@comment "
pre-everything::
.if ${ARCH} == "i386"
-.if defined(WITH_BDB) || defined (WITH_TRANSLATE)
+.if ${PORT_OPTIONS:MBDB) || ${PORT_OPTIONS:MTRANSLATE}
@${ECHO} 'BDB/LibTranslate support may cause breakages in depended apps on ${ARCH}'
@${ECHO} 'Use it with caution'
.endif